Unable to receive IFC / deserialization errors


Looks like receiving IFCs is broken again. Tried it both on Archicad and Revit, deserialization errors on both. Looks something like this >

Hey @Andrei , thanks for flagging this up - does it happen with any IFC files?
If not, and if it’s specific to the one you’re using, could you please send us a copy?

I tried two different IFC files in both revit and archicad, so im guessing its a general issue with the ifc format.

We’ve logged this and will investigate; thanks for the report @Andrei ! :pray:

Hello everybody!
We have the same issue with different ifc files:
Tested in Revit.
Are there any ideas in the meantime?

Hi @ba.ja - welcome to the Speckle Community, feel free to introduce yourself in our introductions discussion!

Sorry to hear that you are having problems with IFC.

Can you please provide the ID of the Stream and branch you were attempting to import the IFC file to (or copy the url)? I can then investigate and try to find the source of the error.


Hi @iainsproat and thanks. Also for the hint :slight_smile:
Here we go:
Thank you!


Super cool, what are you working on?

Thanks. In this case we’re planning a new rail bridge. We got some model data from the surveyor and want to make it usable for revit. We want to have it easier with display settings etc. than with an simple ifc.


I’ll just throw out that I’m also seeing the same thing. This is from a native IFC upload to a stream and attempting to receive it in Revit. We are trying to receive existing information from an AOR that is working natively in ArchiCAD.


@ba.ja If you were able to share the source IFC with us, we think we have identified what may be triggering that error report, but it isn’t clear if it is caused by the IFC uploader or if the source data in the IFC is at fault. It would be good to compare.

@jonszcz likewise, if you have a minimal example that is failing for us to debug, that would help a bunch.

What is the best way to share an IFC file. This isn’t our file to start with, so I’m a bit dubious about posting it on the Forum for now.

The forum allows for DMs (click my name), and you can share any file link.

The ideal way to avoid leakage of secrets is to share the smallest portion of a file that causes the problem, but if you aren’t authoring IFC then this may be difficult.

That’s right. It was a direct IFC upload into the stream.

A post was split to a new topic: Uploaded IFC not displayable in the viewer

Hey @ba.ja , @Andrei

thanks for the report, we’ve found the problem with our material conversion logic in the IFC parser.

We’re going to include the fix in the upcoming release.

Thanks for bearing with us


Thanks for the update, great news!

1 Like

Great news :slight_smile: I’m looking forward for the update.
Thanks to the whole speckle team :+1:

1 Like

Hey @ba.ja @Andrei

we’ve just release a new version of the Speckle server ( 2.16.0 ). It pushes out the ifc parser fix too.

I’d appreciate you testing if the fix works :slight_smile:


Great, thanks a lot @gjedlicska !
Do I have to push the model data once more into the stream?