Unable to login

As per the email (Your Speckle Automate Starter Pack - 2 of 3), I tried to login on Speckle Automate. I gave it a try in Firefox and Chrome but got the same result.

I already had an account on latest.speckle.systems using the same email address as I got the email on and I can successfully login:

When I visit automate.speckle.dev and click the login button on the top right, I get the following 3 pages without me clicking on anything else.

Page 1: disappears very quickly before I can click on anything so I can’t Deny or Authorize it. It seems like it automatically tries to authorize. Is automatically authorizing as expected?

Page 2: auth seems to be successful :slight_smile:

Page 3: ah to bad :frowning:

1 Like

@JdB @Jeroen_van_Lith1 @nmered

This was a misstep on my account. I sent the emails right after adding you to the approved list - the server shunt hadn’t completed that enabled access.

Totally my fault.

You should now be able to try again.

When Automate is no longer part of the beta program, this necessity will no longer be in case; it is a management issue of the multiple domains we are currently using.

Again apologies.

No worries! This is part of the Beta “fun” :slight_smile:

I tried again and I still can’t login. Page 3 has changed to (the others are the same):

Hi @JdB - sorry about this, it should now be resolved. Could you please try again and confirm whether you can log in successfully now?


Great stuff, it’s working!


What about my question regarding automatically authorizing, is this as intended? I think users should have the ability to deny an app that requests access to their account.

Ok, glad its working now!

For third party applications, users are presented with a screen that allows them to accept or deny permissions for an application. For a Speckle-created, “first-party” application, we can skip that.

1 Like

@JdB This first-party is equivalent to the GraphQL explorer application.

For now, yes. As the onboarding notes suggest, this is a tear-down testing server not intended fro production information. Nevertheless, your point is well taken and noted.

That said, in its future integrated form, Automate will probably need more guards around the compute consumption at a personal/project/organisational level than the app approval itself.


Yesterday we’ve pushed a fix, that will stop the “Unable to connect” case happening again. Let us know if you have any more issues with login ( i hope you wont )

Hi, I am also getting the aforementioned 403 error for my account. Could I get some help logging on, please?

1 Like

Have you verified your account on Latest?

Getting a bit of the same issue as the others. I’ve followed the steps noted above using the same email that is verified on latest. I did receive two activation emails when I logged into latest.speckle.xyz.

is that account on latest the one I have whitelisted for access?

Haitheredavid[at]gmail.com ?

Screenshot 2024-04-05 113342

let me see what is going on.

Can you try again? :spockle_smirk:


success! the magic JustWorks™ is in action now :slight_smile:

1 Like

It is amazing what magic turn-it-on-and-off-again can perform

Have You Tried Turning It Off And On Again GIFs - Find & Share on GIPHY


I thought I had:

It’s an authenticated application, but is your account verified?