Tekla Structures Connector 2.14.3 crashes - 2.13 does not


Trying to test the Speckle Tekla connector, but i receive an error message when opening the Speckle.ConnectorTeklaStructures (error in attached. image)

We haven’t seen this error in a very long time. It has been related to the UI library we have in the past.

Can you confirm the version of the Tekla Connector you were testing?

Hi, I had this issue with 2.14.3 (newest) in TS2022 and TS2023 both.

I tried now with an older version (2.13.0) There it works

1 Like

A post was split to a new topic: How to view Tekla data in PowerBI - no objects visible

Hi same here, just install 2.14.4 and it crash everytime you want to click to open or see properties.

Crash report inside Tekla

We experienced the same issue with Tekla connector V2.14.4, installing 2.15.0-alpha4 solved it for us.
Issue: starting Tekla and opening a model works fine, but when you want to start the Speckle Tekla connector then Tekla crashes with that same error as shown in the opening post.

1 Like

Hey @Thomas-Lcp @JdB @Morten.Kaasik , apologies for the slow reaction, we’ve managed to fix both the installation and startup issue.

Can you please check with our latest alpha release?


1 Like

It doesn’t open at all. Clicking or double clicking does nothing in Tekla 2023.

I’m able to start the Speckle connector in Tekla Structures 2022 by searching for Speckle in the Quick Launch bar in the top right corner. I only tried receiving as direct meshes, which works like a charm.

This also doesn’t work for me ! Speckle doesn’t start anyway.
i double checked and I use the last 2.15.0-alpha5 plugin version.

Hi, in TS2022 it works for me, (alpha5)

1 Like