Still Can't Get Archicad Connector to work

I’ve managed to get Speckle to appear in my Archicad menu, but nothing launches when I activate it. The installer put the add-on files inside my application support folder, not directly into the Archicad Add-ons folder. I found it, moved it into place and from there I could see it in the Interoperability menu, but nothing past that.

Hi @abourgoin,

Which version of the Archicad connector do you have?

Hi @jozsef.l.kiss

I’m also having troubles installing the Archicad Connector for Windows.

  • I tried installing it via the Speckle Manager 2.9.8.
  • I tried installing the latest offical version of the connector 2.12.4 as well as well as 2.13.0-rc2.
  • I also tried to install it manually with amin rights from the download page.
  • I have both the german version of Archicad25 and 26 with the latests updates installed.
  • Archicad26 is in the 30 day trial mode and Archicad25 in demo mode.
  • The Plugin is not showing up in the Add-On-Manager

Archicad Version:

Version Sprache Build Platform Typ
26 GER 4022 Win64 FULL

Speckle is installing the Connector to the follwing location:

The standard folder for Addins in Archicad is as follows:
C:\Program Files\Graphisoft\Archicad 26

I would be very thankful for any kind of help.

Thanks a lot and all the best, Lukas

Hi @jozsef.l.kiss

I just found this post on the forum and it seems to be the same issue and it also works for me.

1 Like

I have Archicad 25 and 26 for Mac, both updated to current build.

sorry, jozef,

I’ve loaded 2.13 beta 6, for Archicad and Rhino.

Hey folks, @abourgoin @herrlukas any luck with the latest release?

no luck as yet. The speckle Manager installed v2.13.3 (Alpha). This landed in my Add-Ons folder as a bundle file. I can see an item in my Interoperability menu that doesn’t do anything.

I added the "ALPHA Speckle Connector) item to one of my toolbars via my Work Environment settings. When I click it, nothing happens.

Could you please try it with 2.14-rc10? We’ve fixed quite a few issues around the installer in that version. Thanks!


Thanks Jozsef. I was able to send something to a stream with this version. Now to figure out how to consolidate elements to a stream and view them. Happy to be abele to start experimenting.

1 Like