Speckle not installed on Blender 4.0

I’m having the same error on Blender 4.0. does this connector work for this version?

Hey @Andries_Pieterse .

Welcome to the community! Feel free to Introduce yourself :person_gesturing_ok: to the community if you want to! :grinning:

Is Speckle the first plugin you installed in that Blender version?

Hi Gokermu

I’m so sorry. I work for an engineering company as an animator and AR developer. So this plugin is amazing as the BIM team generally works in Revit and Navisworks (huge models). For animation we have moved to Blender but a quick and easy way to move models between these programs is difficult. This software is a gift to the industry.

I have other plugins also enabled on Blender that I use for my animation.

Can you send a screenshot of what you have in the following path:

C:\Users\{user}\AppData\Roaming\Blender Foundation\Blender\{ver}\scripts\addons

This is the screenshot of the entire error.
I tried installing a previous version but the same error.

Thanks for sharing this. Can you also share the screenshot of the following directory:

This one

I noticed that you have BlenderBIM installed. We have received reports of conflicts between the two plugins dependencies. Unfortunately, we have not yet been able to solve the issue. However, you can find a workaround in the following thread.

Thank you so much this helped

1 Like

Hello All,

I am a novice in both blender and Speckle.

Installed are Blender 4.1.0 and Speckle 2.18.1 according to instructions, including saving a blender file, quitting and the installing Speckle via the manager.

If those version are compatible , please help me determine what I have done wrong.

The only add-on item is Speckle. The Manager dialog box says compatible with Blender 3x. I installed 4.1.0 as from previous discussions it seems that they are deemed compatible.



Screenshot 2024-03-29 174106

For me these are compatible.
I just installed Speckle in Blender 4.1 official and 4.2 alpha.

There are a few things that could go wrong but you said you did those already
Yes, you have to start your Blender first. To force Blender creating its
Settings Folder Hierarchy, some mention you should do some changes and
save a any file and/or do some changes in Settings and save Settings.

Speckle Manager will search for those Blender Settings Folder
and install Speckle inside.
But for me that did not always work. I usually have 2-3 Blender versions
installed, each has its own Setting Directory. Although these Blenders
were already in use, sometimes some of these AddOns are missed by
Speckle Manager Updates for some reason.

But I see your Explorer screenshot and it looks like installation
worked as there is already the bpy_Speckle Folder in

And I see the screensho of Blender Settings that does not show
The only reason I can imagine is that you have to start Blender again.
If it is still not in AddOns, try to set the Filter from all to “Scenes”.
That Scenes filter entry is added by Speckle.
Maybe it is needed to make Speckle to appear in the list.

And if Speckle appears, maybe it is not yet activated.
When successfully activated (Not aborted by that error log popping up)
it should appear in “N” Palette on the right and maybe do another Blender
restart to make it work.
(I had it once accessible but it did not work before another restart)

I think I found your Problem.

If Speckle is not yet activated - it can’t appear in your AddOn list
as long as you filter for “Enabled Add-ons only”


UPDATE: Speckle was installed on both Mac OS and Windows, running Blender 4x and 3x respectively.

The issue was that there is a warning in both OS’s, and Speckle is not enabled automatically. Thus, when the “Enabled Add-ons Only” is checked it will not show up. If that is unchecked, Speckle does show up, not checked. There is a warning, which can be ignored, and then checked manually.

There-after it works are expected. I have to find out what WIP means. Assumption is “Work in Progress”, which would be OK.