Speckle ETABS Connector

While Rey wakes up I can only provide some unhelpful advice:

  • can you please try reinstalling the connector?
  • does it happen with any element?

Hi @mahesh_G_K ,

Which version of the ETABS connector do you have installed ? and do you have other connectors installed as well ?

Regards,
Reynold

2.4.1.11938, yes I have 5 other connectors as well.

@Reynold_Chan

I tried reinstalling, it still doesn’t work
I tried one element from each type, it didnt work

I think it is unable to send and receive both, it gets stuck here
image

image

If I want to force stop this, I am not able to use the Cancel - exit happens when I close from taskbar.

After which, if I try save (scenario - nothing was really transmitted) then I get this -
image

At the very end of exiting the application this -
image

I suppose either it is getting stuck in some loop or not able to connect via the api, some exception handling along with time check to be introduced here may be ?
or else if there is a way to debug the same please let me know.

@teocomi
I ried relaunch, reinstall, restart, reinitiate every clean way on send and receive both, it didnt work for me :confused:

HI @mahesh_G_K ,

Don’t reinstall. I’m aware of this bug with version 2.4.1 and other connectors. This is a fix we’re working on for 2.5.0 release which is coming soon. In the meantime , if you would like to try out the ETABS connector, please try the alpha release of 2.5.0. You can do that by going to this website : speckle-releases

If you toggle down the side you will see an option to download the alpha. Note: you need to do this for the other connectors as well.

image

Let me know if this helps and if you want you’re more than welcome to hop on a debug call with me directly.

Regards,
Reynold

Hey @Reynold_Chan !

I installed the 2.5.0 alpha one, it is throwing an error like this -
image

there are no alpha 2.5.0 releases available for both rhino and grasshopper, is that causing this issue ?

Hi @mahesh_G_K

Yes in this case please uninstall the rhino and grasshopper connectors completely. And reinstall only the etabs connector.

Let me know if this works.

Yes, it did.

But not completely. I have just tried frames and slabs. Frames went through but not slabs. Also there are some extra elements which came I guess. Anyways I was just exploring/ trying out.

Thanks

Hi @mahesh_G_K ,

The slabs should have went through, but there’s a known viewer problem currently. If you send only the slabs and explore it in the object viewer, you should be able to see the properties of the slab. Let me know if you still don’t see it . Assuming you used the all filter, there are gridlines being sent as well , and other properties inside the Model. Thanks for testing !

Cheers,
Reynold

1 Like

Hey @Reynold_Chan

I see the slabs went through but they are not visible in the viewer (only the corners are visible). Also I tried to receive from the streams, all and part (only slabs) model and see the following -
image

1 Like

3 posts were split to a new topic: Grasshopper ETABS Components Missing

3 posts were split to a new topic: Using ETABS21 and Speckle

11 posts were split to a new topic: Receive ETABS force data in Revit

9 posts were split to a new topic: ETABS analysis results reporting to Speckle