Speckle ETABS Connector

Hi @Tushar_Nagananda

I’ve been perplexed these days in terms of how “spreadsheets for days” in rhino would look like that wouldn’t just end up being a fancy viewer of the ETABS viewer itself ? Any examples of any sets of data you would like to visualize in particular that the ETABS viewer doesn’t do a good job of itself inherently that Rhino might be able to do a better job?

So If I have a bunch of walls or coupling beams in a high rise tower and I want to view envelope loads of all my load combinations etabs takes a while to generate all that information over and over again.

Once you export it all into a spreadsheet, visualizing it into rhino would be nice to

  1. have it on hand to refer to.

  2. send it to the web if needed to describe something to another team member.

A good example is design changes. Lets say over the course of SD to DD I change my wall design 4-5 times due to architectural changes. It would be nice to know why I designed my wall how I did based on some diagram of the forces or how the model behaved at one point it time (forces being a proxy)

In the past we would just create a PDF of elevations with forces and maybe drop the EDB file

but im just thinking out loud

2 Likes

New ETABS tutorial here: Short Tutorial for Revit to ETABS and back (Alpha)

Enjoy !

Reynold

2 Likes

Hi Team,

I am trying the etabs connector on v18, both send and receive are not working for me for some reason on very simple template models. The progress bar just keeps on showing progressing but doesnt conclude the transaction. Please anyone can help me in this.

@teocomi @Reynold_Chan any thoughts here ?

While Rey wakes up I can only provide some unhelpful advice:

  • can you please try reinstalling the connector?
  • does it happen with any element?

Hi @mahesh_G_K ,

Which version of the ETABS connector do you have installed ? and do you have other connectors installed as well ?

Regards,
Reynold

2.4.1.11938, yes I have 5 other connectors as well.

@Reynold_Chan

I tried reinstalling, it still doesn’t work
I tried one element from each type, it didnt work

I think it is unable to send and receive both, it gets stuck here
image

image

If I want to force stop this, I am not able to use the Cancel - exit happens when I close from taskbar.

After which, if I try save (scenario - nothing was really transmitted) then I get this -
image

At the very end of exiting the application this -
image

I suppose either it is getting stuck in some loop or not able to connect via the api, some exception handling along with time check to be introduced here may be ?
or else if there is a way to debug the same please let me know.

@teocomi
I ried relaunch, reinstall, restart, reinitiate every clean way on send and receive both, it didnt work for me :confused:

HI @mahesh_G_K ,

Don’t reinstall. I’m aware of this bug with version 2.4.1 and other connectors. This is a fix we’re working on for 2.5.0 release which is coming soon. In the meantime , if you would like to try out the ETABS connector, please try the alpha release of 2.5.0. You can do that by going to this website : speckle-releases

If you toggle down the side you will see an option to download the alpha. Note: you need to do this for the other connectors as well.

image

Let me know if this helps and if you want you’re more than welcome to hop on a debug call with me directly.

Regards,
Reynold

Hey @Reynold_Chan !

I installed the 2.5.0 alpha one, it is throwing an error like this -
image

there are no alpha 2.5.0 releases available for both rhino and grasshopper, is that causing this issue ?

Hi @mahesh_G_K

Yes in this case please uninstall the rhino and grasshopper connectors completely. And reinstall only the etabs connector.

Let me know if this works.

Yes, it did.

But not completely. I have just tried frames and slabs. Frames went through but not slabs. Also there are some extra elements which came I guess. Anyways I was just exploring/ trying out.

Thanks

Hi @mahesh_G_K ,

The slabs should have went through, but there’s a known viewer problem currently. If you send only the slabs and explore it in the object viewer, you should be able to see the properties of the slab. Let me know if you still don’t see it . Assuming you used the all filter, there are gridlines being sent as well , and other properties inside the Model. Thanks for testing !

Cheers,
Reynold

1 Like

Hey @Reynold_Chan

I see the slabs went through but they are not visible in the viewer (only the corners are visible). Also I tried to receive from the streams, all and part (only slabs) model and see the following -
image

1 Like

3 posts were split to a new topic: Grasshopper ETABS Components Missing

3 posts were split to a new topic: Using ETABS21 and Speckle

11 posts were split to a new topic: Receive ETABS force data in Revit

9 posts were split to a new topic: ETABS analysis results reporting to Speckle