Rhino plugin fails to load

What does it say when you click under “details”?

It might be a DLL conflict: FAQs | Speckle Docs

Hi there, and thanks. I am using Rhino 7 and Rhino 8 (The error occurs in both).
Below is what I see when I click on more details.

I’ll check the DLL link you sent…

Rhino 8 will only work with Speckle >=2.19 (currently available in Manager with the Show Pre-releases toggle) and Rhino >=8.3

Check if the other Speckle connectors installed do not match. It is best if the versions align—particularly between Rhino and Grasshopper but generally all of Speckle connectors. If the Manager shows this:


It might be good to check that everything is version-aligned.

If you have installed Speckle connectors in the past as an admin account, you may want to do additional cleanup, so if you uninstall and reinstall, we should take care of that.

Thanks Jonathon. I am only running Speckle for Rhino. I used to have Speck for Blender, but uninstalled it as the versions did not align and I wanted to trouble-shoot if that was the issue. I still get the error.
I am the admin so that should not be an issue. Should I check for unwanted files in the appdata folder?

Prior conflicting installs could be:

Installed for all users
C:\Program Files\Rhino 7\Plug-ins
C:\Program Files\Rhino 8\Plug-ins

Installed for single user

Thanks. Should I just delete what I see related to Speckle?

Try using the Manager uninstall first, but can confirm there

Was this able to get you unstuck?

Sorry. Was away… Still no luck here.

I also get this when uninstalling the manager. I wonder if I need to uninstall and delete everything Speckle related, then start fresh. If that seems like the right method, can you let me know from where else I should be removing files?

Anyone else have a solution here?
I’ve been through all the post with similar issues, but still can’t resolve it.

Can you specify what you mean by “also get this”?

Did you do this for the folders I specified?

Something that worked for me when i had the same problem:

  1. Close all Rhino versions
  2. Open Task Manager
  3. Search for Rhino
  4. Terminate all tasks related to Rhino, check both Apps and Background processes
  5. Open the Speckle Manager
  6. Uninstall Rhino and Grasshopper Connectors
  7. Re-Install Rhino and Grasshopper (2.18.4)
  8. Open Rhino 7 and wait - it needs few seconds to install the Rhino Connector

If you want to use Rhino 8 you need to Install the Wip Version (2.19.0-wip).
Follow the same steps.

Jonathan. What I mean is I get the same error when opening Rhino 7

@Nikos I followed you guide. Nothing related to Rhino was running in either Apps or Background processes.
I followed steps 5 through 8 and go the above message.
Re step 7 I only see 2.18.4 for GH, Rhino is 2.18.3 correct?

Hi Brian,

Is this the first time you use the connector, or was it working before?

I would suggest trying to do a clean install, see the instructions here:

Hi @teocomi . I really appreciate all your help. This is not the first time I have used Speckle. It was working well between Rhino and Blender, but somewhere along the what it just stopped. I will go through the steps of a clean install and report back.


@teocomi No such luck. Could have anything to do with Blender? I saw this in the app date folder for Blender 4.1

C:\Users.…\AppData\Roaming\Blender Foundation\Blender\4.1\scripts\addons\bpy_speckle

Hi Brian, I’m sorry this must be frustrating - it’s unlikely that Blenderis conflicting.
If you have 15 min we can try debug it together tomorrow: Notion Calendar

Just scheduled. Thanks, Matteo.

1 Like

For anyone having a similar issue, we’ve found a workaround:

  • Install the Rhino Connector
  • Open Rhino (it will show the error dialog)
  • Drag the file SpeckleConnectorRhino.rhp from the folder %appdata%\McNeel\Rhinoceros\7.0\Plug-ins\SpeckleRhino2 (8dd5f30b-a13d-4a24-abdc-3e05c8c87143)\ onto the Rhino window
  • This might take a few seconds, as it triggers a manual installation of the plugin
  • The plugin should now be working

PS 1
Ensure that the Plugin is enabled in the Rhino Options

PS 2
The path above can be easily copy-pasted in your Windows Explorer window

1 Like