Rhino 8 2.19 wip not working

Hi all,
I tried to install the speckle connect for Rhino and revit. Revit just worked fine, but on Rhino it doesn’t show anything, I don’t know why is not working.

Actually it worked on Rhino 6, but Rhino 8 which I have just a trial license it didn’t work. (not sure if it makes difference, the license)


Hi Guilherme,

Welcome to the Speckle! Feel free to Introduce Yourself if you feel like it🖖!

I moved your post to this thread here.

To use Speckle in Rhino 8 you need to install 2.19.0-wip2 Rhino Connector. And for the best experience, also upgrade the Revit plugin to the same version.

Please read this comment for more instructions:

I hope this is helpful.

Thank you.

Hi Nikos,

I’m also having the same problem, the Speckle connector is not showing up in Rhino8. I did install the 2.19-wip2 and tried wip3 too, but with no success. I also tried to change the dotnet runtime, but still not working.
I also have Rhino 7 installed and Speckle works fine there.
Any ideas how can I troubleshoot this?
Thank you!


1 Like

Hi @palbo

I´m sorry to hear that you are experiencing issues with the Rhino Connector.

Can you please try to install 2.19.0-wip. This version is recommended for Rhino 8 but still WIP.


Let me know if you are still having problems.


I’ve been having this issue too. I’ve tried 2.19.0-wip, 2.19-wip2, and 2.19.0-wip3. I think the issue is that when I install any of these from the Manager for Speckle, it creates and installs Speckle in a new Rhino 7.0 folder rather than installing in the Rhino 8.0 plug-ins folder. I had both Rhino 7 and Rhino 8 installed, so I uninstalled Rhino 7 along with all connectors. Then I went through the process and tried to reinstall the connectors again. It still creates a new 7.0 folder and installs Speckle in the 7.0 plug-in folder instead of 8.0. If I manually move the SpeckleRhino2 folder into the 8.0 folder, I can follow the work around to get it to show up…but I still have to follow the workaround of manually loading the plug-in and changing the dotnet runtime setting.


Hi @Mamidon,

Thank you so much for sharing your solution. This is very helpful for us.

The Rhino 8 connector is still WIP, the team is working on that and we are expecting new updates soon. :rocket:


Thanks Nikos!
Yes 2.19.0-wip works!

1 Like

Hey @Marc_HERMOUET @Jmathers @RH-gmiranda @palbo @Mamidon ,

We have released a new WIP version for the upcoming 2.19 release. This version includes a fix that correctly installs the connector for both Rhino 7 and Rhino 8. Any conflicts or errors that were previously encountered should now be resolved. Could you please check this version and let us know if it works for you?



You and your team are awesome. Works great. I freaked out for a second after opening Rhino 8 and getting a “failed to initialize” error, but that was just because SetDotNetRuntime needed to be set back to “default”.