Question: How can I resolve this blender error when trying to install Speckle

Oops. That’s not good.

To start trying to resolve this for you, can I ask how you’ve installed the Speckle for Blender plug-in? Have you used the Manager or by other means?

Yep, I installed the Blender plug in through the manager. Could it be because I’m not using the latest version of blender or speckle?

1 Like

I think it should work for Blender 2.93 anyways. I’ll try to reproduce this on my end and see what’s the reason behind it.

Just to be on the safe side, did you try restarting Blender and see if it helps?

Ok, looks like we’ve changed some things and it doesn’t work on 2.93 anymore. I created an issue and we’ll tackle this asap. In the meantime you can install 2.7 release. I tested it and it worked on my end.

I’ll let you know once we fix this issue.

1 Like

Hi @Samantha_T

I’ve just pushed a fix for our connector on Blender 2.93.
You should see a new version 2.9.1 of the connector now on manager.

Hopefully this fixes all your issues.


see related discussion

2 Likes