Power BI Connector not showing up

hello im not finding any custom connector folder in my document drive to keep the .mez file .
i have also created one folder and select the third party connector access in power bi , but still the speckle beta not showing … plese help


Hey @bikash_muduli ,

If the Custom Connectors folder doesn’t exist, you can create it under Documents\Power BI Desktop. Then copy the downloaded Speckle.mez file there.

If it still doesn’t work, can you share a screenshot of that folder?

Hi @gokermu ,

i’m an other user then the one starting this topic.
But i myself am also able to see the connector showing up in powerbi.

below a screenshot of the folders:

I also see that i have a second documetns folder on one_drive so i did the same thing there just to be sure:

Hey @BB_Alexander welcome to the forum!

Sorry the PowerBi connector is not working for you, we’re palninng to focus on in our next development cycle so expect news in the next few week!

We’ll reach out again soon to ask for more info :slight_smile:

1 Like

Hi @BB_Alexander!

I’m not really sure what could be going here. We just follow Microsoft’s recommendations

It’s not enough to just copy the connector, you also need to change your settings to allow PowerBI to load it :wink:

Let us know if that doesn’t work!

Hi @AlanRynne,

Also did the settings and reload a few times.
Checked the spelling of the folders.

Still no succes.
I know its not much to go on but i do have a documents folder under my user-folder and a synced one on Onedrive could have anything to do with it?

is there a possiblity/ setting that could make it possible that the third party apps are in a different location?

This could be, but we have no way to control how PowerBI supports (or not) synced user folders. As far as I’m aware, PowerBI shouldn’t care as long as the file exists in the path it’s looking for though…

Are you using a Corporate Device? How is PowerBI installed in your computer? If you’re under a managed device you may have some custom installation that prevent’s these from loading regardless of your settings.

Sadly, I think you may have to bring this up with Microsoft’s PowerBI Support directly, but it does seem you’d need to be a Pro license holder Support | Microsoft Power BI

Hey @BB_Alexander, I’ve been doing some improvements in how we ship the DataConnector which may potentially fix your problem.

I built a .exe installer that should:

  • Sign the DataConnector with our own certificate
  • Copy the DataConnector to it’s expected location
  • Add a Registry Key that tells PowerBI Desktop that this is a recognised custom connector.

To be honest, I’m not 100% sure this will fix your issue, but we might as well give it a shot.

Could you download the installer from here:

This will take you to our CI page where you’ll see 3 links. Download the last one. powerbi.exe and run it. This will require admin privileges

Screenshot 2023-04-26 at 11.48.34

If you’re curious about the details, you can find more info about this here Trusted Third-Party Connectors in Power BI Desktop - Power BI | Microsoft Learn.

Note that if this doesn’t get PowerBI to recognize the connector, you can uninstall it from “Add or Remove Programs” in your windows machine, and it will remove the registry key too :wink:
Screenshot 2023-04-26 at 11.51.31

You’re the first one I’m sharing this with, so if something unexpected happens don’t hesitate to let us know! :raised_hands:t3:


Hi @AlanRynne,

i’ll give it a shot this afternoon and come back to you with some feedback later today or tommorow :).
thx for the fast responce btw!

1 Like

Hi @AlanRynne ,

Below you can find my feedback on the installation file you provide in your previous post:

  • the install is succesful in that:

i also noticed that both an english and dutch version of the documents-folder exist now in both location. i think the english one was created by the install.

There are alot more files from other programs in the dutch version tho.
So i copied the files from the englisch version to the dutch one also (just to be safe).

i also did a fresh install of power Bi desktop.

After all these trys (steps) nothing seemed to help in solving my issues to find speckle in power bi:

Finaly i went back to the power bi page with instruction and noticed this note:

Could it be that it has something to do with this?
some other settings need to be changed?

also the certificated installed corectly:

Thanks for coming back with this @BB_Alexander

Yes, I guess the installer needs to be multi-language aware before releasing it officially. The Documents folder was surely created by our installer.
The registry key thumbprint value also seems correct. :+1:t3:

This issue refers directly to the pop-up you should get at startup:


Do you get this warning? In theory, the registry key addition should prevent that warning from appearing on our connector.

Getting this warning would be a good sign though, as it would mean your PowerBI is finally picking up the connector.

I also recommend deleting the previous .mez file. As I’m not sure how they would conflict with one another :wink:

@AlanRynne the strange thing is i never (from the start of trying installing speckle for Bi).
received or manage to trigger the pop-up.

Thats why i think the is some pathing issue goign on.
And that PowerBi just doesn’t find the folder structure for the connector.

Well I’m sorry to say I’ve ran out of suggestions :cold_sweat:

I’m not sure it has anything to do with the language in your system as other user’s have been using the data connector and visual without any issues.

It may be that the OneDrive integration is doing something funny with your user path and that’s causing PowerBI to not pick it up.

I tried hooking up syncing my user with OneDrive but that seems to work fine on my end too… :frowning:

I’m reaching the point of “silly suggestions” now…

  • If you have admin priviliges on your computer, could you create a new user (offline, no microsoft account) and try the custom connector there?
  • If that doesn’t work… in that same test user: Would it be possible to change your language to English and see if PowerBI Desktop figures it out?

Testing on a separate user on your machine will allow us to figure out if OneDrive or system language is to blame for this problem. :slight_smile: without wrecking havoc on your machine’s setup

i Can only thank you @AlanRynne for all the help you have already given.
I will contineu my endavour to get this working :wink: !

When i would find some hard evidence in some direction or conclusion i’ll let you know!
i can’t stress this enough that i’m really thankfull for your help in this issue!

Keep up the great work and we will figure this beast/monster out


Hi @bikash_muduli ,
have u also tried the install that Alan provided in the discussion below?
are you also using a corperate divice with a onedrive connection for your documents?

i’m trying to look for simularitie between our cases.

Hi community, Despite downloading Power Bi (from Microsoft Store), Im not able to locate Power
Bi folder in my Documents. I searched for Power Bi in C: and created a custom connector folder in folders that had Power BI Desktop named (highlighted in red) and the connector still wasn’t showing up on Power Bi app. Is there a way around this?

1 Like

You can make the

YOUR_USER_FOLDER\Documents\Power BI Desktop\Custom Connectors\

Folder yourself. I have seen it created on installing Power BI Desktop and sometimes not created - somewhat inconsistent.

The PowerBI app isn’t fussy about where it installs Visuals from, but that works for Connectors.

Then you’ll need to go to Settings -> Security -> Data Extensions and activate the following option:

Allow extensions to run

Checking the connector is loaded

Now open PowerBI, and you should see Speckle (beta) appear in the data source.

1 Like