Issue loading speckle on rhino 7 Mac

hi guys, I am having some troubles loading speckle into rhino 7 on Mac OS. i am not sure why this does not work, I tried typing “speckle” in the command tab but it doesn’t do anything (not an issue with command tab it opens grasshopper with ease)
I verified the plug-in manager and speckle is already enabled. I also have installed the connectors in the speckle manager. I can’t find speckle anywhere on rhino hence I am unable to create stream nor send models !
in desperate need of any advice possible. thanks guys !

n.b speckle does appear in grasshopper

Hey @Keelyan welcome to the community.

I can see from Manager your versions are misaligned between Rhino and Grasshopper. Under the hood they share a lot of code. It is important to make sure they are at the same version or only install one.

This is one of the issues the warning is about at the top of Managers installs list.

Thanks for the quick answer !
I downgraded both connectors on versions 2.18.0. still doesn’t appear on rhino …

Have you tried doing a clean installation (uninstall everything and install again)?


Hi gokermu, just did that, and re installed both rhino 7 and speckle manager. but it still doesn’t do anything whenever I type speckle in the rhino command bar.(went into the plugin manager to see wherever the speckle plugin was enabled or disabled. spoiler alert it was indeed enabled)
running short on possible solutions…
thank you for your help though

A post was merged into an existing topic: Connector suggestion: AutoCAD 2024 for Mac

Hello, I’m facing the same issue here, Speckle Connector is not loading for Rhino 7 on macOS.
I have just installed Speckle for the first time, it couldn’t be cleaner than this.:slight_smile:

My versions are aligned at 2.18.3 (apart from Blender, but shouldn’t be a problem, right?):

I have the Speckle-related commands available:

Speckle also shows up as loaded in my plugins folder:

The plugin is installed here:
/Users/{username}/Library/Application Support/McNeel/Rhinoceros/MacPlugins/SpeckleRhino2/Release Mac/win-x64/SpeckleConnectorRhino.rhp

@jonathon hence my Rhino 8 compatibility-related question in the other thread (I didn’t want to pressure you into stating deadlines, I was curious whether this will have a solution in the near future, as right now I can’t run Speckle on my laptop for Rhino at all – and I’m away a lot from my PC, so this is quite problematic at the moment and I’m short on disk space to experiment with Rhino 7 on Parallels).

OS: macOS Ventura 13.6.4 (22G513)
HW: M1 Max MBP 64GB
Rhino: Version 7 (7.36.23346.16352, 2023-12-12) (latest according to “Check Updates”)

I’m looking forward to hearing your thoughts and experience on how to resolve this, I couldn’t find a thread about this so far.


Cool (not cool)

So this shows it is loaded, but those commands are not functional?

Are the Speckle nodes available under Grasshopper in this case?


The icons look to me partially loaded.
I didn’t try building a script yet, and I won’t be able to play with it today – I’ll keep you updated in the upcoming days. If you want me to check something specifically, let me know.

If simple send or receive works that’s usually enough



By partially loaded I meant the panels (it looked weird that in certain columns only 1 icon is present and in others there are 2) – the dropdown list is OK, comparing to yours.:slight_smile:

I’ve checked by sending a simple box to a random project, it works!

So what’s the matter with the Rhino plugin? ¯_(ツ)_/¯

This is unclear - and haven’t found a situation I can replicate at this point.

OK, i am able to reproduce. We’ll look into this and get back to you.

1 Like

Until we fix it, you can sue 2.17.1 version.

Hi, are there any news on this topic?

1 Like

Hi @wkrt ,

Not yet. We are still investigating the source of the problem. In the meantime, you can use earlier versions as a workaround.

1 Like

@wkrt @furtonb @Keelyan Fix for this issue has been released as part of the 2.19.1 release. Give it a try and let us know if it works for you!


It works, thanks for the fix!