Impossible to load data from Sketchup to Speckle

Hi everyone,

I’m pretty new to Speckle and was trying to figure out how to send data from SKetchup to Speckle for then trying to load it into Revit.
I’ve followed the tutorial ( Getting Started with Speckle for SketchUp (Alpha) )
Installed every bits that were missing. But stil I can’t manage to see any stream in my Speckle connector inside Sketchup. I’ve created a stream on my account, but I don’t see it in Sketchup

I kinda tried everything and I’m out of ideas…
It all works fine on Revit… So I don’t know what I’ve done wrong.
If anyone could help me or have any idea on what could be the cause of the issue, I’m all ears !
Thanks in advance

1 Like

Hey @Theox ,

That’s weird. Do you have multiple sessions of Sketchup open? If that’s the case can you closing all and opening only the file you want to use?

Hi @gokermu,
No only this session is open.
I tried with this file, that I made using Sketchup 2021. Trying with a different one also doesn’t make a difference. I tried rebooting my PC also to see if it was coming from there.

1 Like

Do you have Speckle Manager installed and did you add your account?

Sure :

I even tried to log out and log back in

1 Like

Do you have a speckle folder on the following path?
C:\Users*UserName*\AppData\Roaming\SketchUp\SketchUp 2022\SketchUp\Plugins

Do I need Sketchup 2022 ?
I’ve followed the tutorial for 2021. Do I need to do it again ? and copy the repo from Git to the path you indicated ?
I tried also in Sketchup 2022, I still have the same windows with no stream.

1 Like

I meant 2021😅. Assuming you installed it via Manager.

Yeah I got it

1 Like

That is quite strange. I’ve never faced this issue before. I have last 2 bullets before i passed this to developers:

  • Can you access the extensions warehouse within SketchUp? I’m suspecting this can be related to SketchUp not being able to connect to the web.

  • Can you try uninstalling SketchUp connector? Manually delete all the speckle_connector folders and make a fresh install.

So for your first proposition,

It it said that there is no signature, maybe because Trimble didn’t approve your application ?
I had the no restrictions for the extensions already checked, so it’s not coming from there…

I’m gonna try a fresh installation

1 Like

I meant extension warehouse. Not extension Manager

Oh sorry, Yes I can download extension directly from the warehouse

1 Like

In the meantime I’ve tried installing it on another computer.
Without doing any part of the tutorial ( Getting Started with Speckle for SketchUp (Alpha) )
And I still have the same problem as I have here.

1 Like

@gokermu I tried to have a clean installation, rebooted my PC but it still does the same thing…

1 Like

I have just installed Sketchup2022 for the first time and Installed SpeckleConnector from Manager

I found that disabling and enabling it in Extension Manager after installation caused Speckle Tools to appear.

I’ve tried that also, but it’s not that I don’t see the tools, it’s that I don’t see any stream in my feed. It’s like I have none (which I have as soon as I go to my internet Speckle)

got it, because the connector is essentially a web view, could you right click on the connector window and see if there are any console errors showing int he devtools window?

1 Like

Effectively, It seems that I have some troubles…

If you Refresh while the console is open… CTRL+R