Branches are not Populated in Navisworks Connector 2.16.3

I have the same problem with version 2.16.3. as was mentioned here: Navisworks 2.12.2 not working?

When using Civil 3D connector, it works fine but can’t choose branches I Navisworks or send.


Civil 3D


Hey @KriAnd, welcome to the forum, let’s try and get to the bottom of this.

I have not seen this issue arise for a while. If you were able to follow the steps as described in the previous step, this would be very helpful.

With all things DUI we expect them to be equivalent between connectors, so it is certainly odd, although can be affected by many things. Can you confirm for me:

  • is Speckle Connectore installed from Manager?
  • do you have the same version of Speckle Connector for Civil3D and Navisworks
  • clearly you can see streams but not branches. do you see all of your streams

I’m looking to see something I can pin down in the logs so, everything you can do to help me help you is beneficial.

Hi @jonathon, thank you. I’m looking forward to exploring more of Spekle.

I have reinstalled Spekle Manager and both connectors for Navis and Civil. It’s also the same version and I can see all my branches.

I can send two log files, one with Spekle installed and the other uninstalled. Could you give me a mail or place to put it? I should mention that I’m not an admin by default on my computer (company rules), and when I open Navis in Admin mode there is no Spekle in the ribbon.

Still odd though that Spekle runs in Civil…

could this be an issue:

Do you have any selectionsets in the model, saved views or clashtests?

I have tried with and without saved views and sets. No clash test. Also, different models, but it doesn’t matter I’m afraid.

I’ve looked into this over the weekend- I’ll see if we can get a temporary installer to you later.

Perfekt, thank you. If there are any info or basis I can provide :slight_smile: (files or logs etc) please define it.

@KriAnd to confirm, are you using Navisworks Manage or Simulate?

Simulate 2022 and 2023 @jonathon

I have published a release you should be able to see in Speckle Manager that I hope fixes this.


1 Like

I’m afraid it didn’t solve it. Could I send you anything? example from cmd in dev mode etc?
I use only 2023 Simulate.

hmm ok that is a big shame - i will install simulate to try and replicate on my machine

Hi again, it was solved with the this version:

I tried the other first



ahh perfect - yes i should have been clearer which I hoped you’d check - awesome.

with that good news ill wrap up the changes in there and it will come hopefully in time for 2.17 stable release

1 Like

@KriAnd this is now available as stable release 2.17

Thank you @jonathon I will test it out :slight_smile: :ok_hand: