Automate: Bug Reports

Just a thread for bug reports so I can drop things in one place.

1 Like

Removing a function input from FunctionInputs in C#, pushing that function to automate, and then switching to that new version results in the following API error:

POST] “/api/v1/automations/b31d2766c9/versions”: 400 The values provided for one of the functions doesn’t match its required schema

1 Like

Ahh. We had just beefed up schema validations, perhaps a pesky order of operations is in play

thanks for the report @chris.welch, as far as we can tell this has been fixed.
Could you try again?

Yep can confirm thats fixed


Another consistent UI bug (or confusing feedback regardless) the run duration timer tends to begin at -15ish seconds


As soon as the run switches from Running to Complete it instantly changes to the correct run time

Not a bug, more of a UX thing, I’ve done a couple of demos now where I’ve tried to show people how to create an automation, and my first instinct is that it would be under “new”

When in reality I need to scroll down to “your automations” and then click new there. It’s a bit “out of sight, out of mind” and it’s tripped me up multiple times

1 Like

Thanks for the feedback @chris.welch - we’ve a larger change to the UI on the horizon, so we’ll incorporate this into the design input.

1 Like

Sorry this might already have been addressed in the upcoming UI release, however just in case I have noticed that sometimes the Viewer will double up on results even though when I query the GQL I only have one assigned automation.

The output from the GQL showing one Automation run:

However in the viewer you can see it listing two automations:

I am not sure how to reproduce either sorry as it seems to be randomly occurring

I’ve had similar issues in the UI - what I thought was happening is when you add the automation without running it, it appears, and when you run it, it appears again as another entry. That might not be right - I’ll keep my eyes open for “double-registering” in future

Can confirm, these automations are double-registering


On the function Chris-Welch-Aurecon/Road-Chainage-Markings ( I’ve set up a very simple AttachResultToObjects call:

var polylines = commitObject
	.Where(b => b is Polyline)

	level: Speckle.Automate.Sdk.Schema.ObjectResultLevel.Info,
	category: "Alignments",
	objectIds: polylines.Select(x =>,
	message: "Processed curves");

The automation is working and seems to be finding the objects ( Viewer - Chris’ Second Project - Speckle), but they aren’t being highlighting or isolating in the viewer when I click the dropdown.

…now that I’ve thought about this for more than 2 seconds, I think it’s because the polylines are actually the visualisation of a nurbs curve, and are being filtered out of the viewer? But still, not the expected outcome

We’re looking into this.

1 Like

Update, I refactored the above to point at the Curves that actually appear in the viewer, and the selection still doesn’t do anything, so I’ll wait for guidance on that.

As an aside, in my digging I also found the docs for Traversing Structured Data | Speckle Docs, which might need a refactor or some extension methods to cope with the new use case of Automate functions (currently it all seems to assume a converter).

1 Like

@Jedd is our resident traversal tour guide, maybe he can help with that.

I’ve created the bug reports for the viewer issues, thanks for sending it our way @chris.welch


Holler coming from the depths of DUI3 (spoiler alert): when bringing in automate results in the connectors, to highlight the “offending” culprits we’ll need their applicationIds as well. Sorry to use the public forum for internal feature request tracking :smiley:


You are among friends.

1 Like

@gjedlicska, looks like the filtering on click is behaving as expected now, nice one!

1 Like

I’m now creating another version and defining a context view in my test function:

Road-Chainage-Markings/RoadChainageMarkings/AutomateFunction.cs at speckle · Chris-Welch-Aurecon/Road-Chainage-Markings (

Neither are surfacing in the UI - from the decompiled code it looks like the CreateNewVersionInProject function is never registering to the automation context that a version has been created?

1 Like