Unable to install ArcGIS connector

I am trying to install the ArcGIS connector and am getting this error every time: ArcGISPro is running. Please close it and try again. You might have to restart your machine. I closed ArcGIS Pro, restarted my machine and still receiving this error. Other’s in my organization are receiving this error too. I am on Windows 11 and ArcGIS Pro 2.9.10.

Hi @gtortorici ! ArcGIS connector has been on hold for a while, but right now we are about to release a new version - 2.18, and you can try to install the latest available - 2.18-wip7 from Speckle Manager (enable Show pre-releases toggle).

A little warning is that the plugin targets ArcGIS 3.0 and higher, so 2.9 might have some unsupported functions.

Regarding the installation error, try to check your Task Manager whether some ArcGIS processes are running and end them.

Hope this helps!

Thanks so much for the response @Kateryna !! Unfortunately, we cannot upgrade to ArcGIS Pro 3.x.

In regards to task manager, yes I check to make sure nothing was running. The only thing I caught was ARCGIS daemon and per Esri “A daemon is a process or service that runs continuously in the background on your computer and is often designed to respond to requests from other processes across a network. The ArcGIS License Manager uses two daemons to function: lmgrd.exe and ARCGIS.exe.”

I tried to close this, but it won’t allow me to.

I see, this process might be a blocker. You might access the latest plugin installer directly via the link

For some reason I was able to get it installed on my remote desktop…but still not on my main machine. Same thing happening for others in my organization.

Could you describe some more details? Does the installation process seem to end successfully but you don’t see the plugin when you open ArcGIS?

Try to check whether the new conda environment with speckle- prefix was created, and try to activate it manually (interface might be a bit different for ArcGIS 2.9):

Were you able to test @Kateryna’s potential fix?

Sorry for the delay and appreciate your help!! @Kateryna @jonathon

I have been pretty intensely testing the ArcGIS connector the past few weeks on my remote desktop. I have some comments/bugs that I’ve found. Should I continue posting on this community or do you prefer a direct reach out?

1 Like

Here is the workflow I am following.

  1. Force quitting ArcGIS Pro through Task Manager
  2. Opening Speckle Manager
  3. Clicking “Install” next to the ArcGIS connector.
  4. I immediately get the “ArcGIS is running…please close it and try again. You might have to restart your machine”
  5. I have tried restarting my machine and no luck, same error

Please note that this is happening to everyone in my organization on their laptop. However, I am able to get the same workflow to work on my remote desktop, which is the same setup.

1 Like

Thanks for getting back to us! What is the outcome if you run the installer I shared above without using Speckle Manager? It does not rely on checking whether ArcGIS is already running

Hi @Kateryna, I am on ArcGIS Pro 2.9.11 so that is not an option for me. We cannot upgrade to 3.x.

This should be fine, this installer is identical to the one in Manager

I mean to say that the suggested workflow is not applicable for ArcGIS Pro 2.9.x. It’s only applicable to ArcGIS Pro 3.x