UE5 - Following along with the Webinar and get an Error

I know that Unreal 5 is not officially supported, but I am following along with the webinar from December. After I copy the files into the Plugin folder, it asks if I want to rebuild now (exactly like the video) however when I click yes I keep getting an error:

“… could not be compiled. Try rebuilding from source manually.”

I’ve tried multiple versions from github of the plugin (including the ‘webinar’ branch), and when I delete the plugin from the folder the project opens up without issues.

Is it wrong to assume if it worked in the webinar example, it should be able to work for me as well? or was there other stuff going on in the backend that would prevent it from working at all in UE5?

1 Like

Hi @RJCoolpix880,

It’s nice to hear some interest in UE5! :raised_hands:

The webinar branch does contain a fix specific to UE5, and it should be as simple as cloning the plugin into your projects’ plugins folder and switching to that branch. What you see in the webinar is exactly just that.

But, it sounds like this also isn’t working for you, which is odd.
Could you try to open the project’s .sln file (in either Visual Studio or Rider), and try and build the project that way? This should give you a more meaningful error message.

Side note: Tomorrow, I plan to merge the relevant changes from webinar to main and delete the webinar branch. I should have done this sooner so sorry for any confusion this caused.

1 Like

Thanks for the update. I tried on 2 computers and it gave the same error. I tried a few rabbit holes on generating the code to open in Visual Studio, and that also gave an error.

At this point, I’m way out of my skill level and think I should just stick with UE4 :smiley:

Regardless - if there is anything I can do to help you troubleshoot to make things better for all, I’ll gladly help.

Sorry you’re having problems, UE5 can be quite temperamental.

I’ve double-checked my end, and the project builds successfully, so I can’t seem to reproduce your issue.

Could you check for an error log in your /Saved/Logs/ folder, this should tell us the reason why the build is failing. You should be able to attach the file to this thread.

I would quite like to get to the bottom of this, as we would like to officially support UE5.

If you would prefer, we could organise a quick call.

Thanks for your persistence.

Note, the changes from the webinar branch are now merged into main

Hi @RJCoolpix880
Any updates? I just want to make sure you got something working, and you aren’t still stuck!