Trimmed surfaces become invalid Breps upon grasshopper send / recieve

By the way this is what I’m getting - slightly different viewport results depending on local data or stream, if that’s any clue! CWS3GjOVTX|690x382


Could you try with just the Grasshopper connector installed? To rule out possible conflicts with the Rhino connector.

That result you are getting is super weird… not sure what to make of it. Lets see if only having the GH connector makes any difference :crossed_fingers:

Okay, just uninstalled Rhino connector and again in both 6 & 7 but still the same consistently weird results! Also tried a trimmed surface without the circular cut-outs and it was fine, as soon as I make a circular cut-out it breaks…

1 Like

Could you share with me the stream you are sending to? Making it public would do too.

It would be helpful to see if it’s the sent data that is wrong, or the problem is when receiving it.

Here’s the stream - I just made it public too

1 Like

Just tried it on another machine here and I have exactly the same problem… :thinking:

Thanks for that! I can confirm I’m getting some really weird results on my end too! I’ll look into it further and keep you posted!

Hi Alan, I was messing around trying different variations of this problem this morning and found that the problem only seems to occur when absolute circles form part of the trimmed surface - it works fine for elliptical curves. I also tried a region union with a circle (instead of circle cut-out of surface) and had invalid result but again with ellipse it was fine. I feel like I’ve had similar issues before like this which I think were to do with curve direction?


Hi @mattm! Thanks for the update.

I did notice that myself, I’ll have a better look today but it definitely seems like the circles are to blame here, although haven’t found anything that is clearly wrong in the data.

I’ll keep you posted througout the day :smiley:

Hi @AlanRynne did you manage to get any further with this issue? Many thanks

1 Like

Hi @mattm!

Yes we have! It seems to be a scaling issue with the Arc conversions coming into Rhino.

Arcs won’t get scaled properly when sent from any other unit than meters to meters. Could you try changing the units of your rhino file to meters and confirming if that is the case in your computer too?

1 Like

Back again with even better news!

We recently changed the way the Arc class was being created, which introduced a small bug that had been lurking for a while unnoticed, as it was not being used until this change.

I already opened a PR for the fix, it was rather small :slight_smile: fix(objects): Fixed arc conversion by passing units to Points.FromList by AlanRynne · Pull Request #767 · specklesystems/speckle-sharp · GitHub

You should get the fix in the latest release :slight_smile: I’ll keep you posted once we do a beta release so you can get it as soon as possible

1 Like

That is great news, I can confirm that changing the Rhino units vastly improved things on my computer. They are all coming through okay as Trimmed Surfaces, however I have some strange display issues with items 0,8,12,13,14, & 15 of the original surfaces. Extracting the edges and re-creating a trimmed surface with them fixes the problem though - see second screen shot.


Hey @mattm!

It seems you are bumping into all the issues regarding Breps :sweat_smile:

The good news is that with the latest fix, most of the problems you reported have been fixed sending and receiving from and to any unit, except for plate 15, which still looks weird.

Screenshot 2021-10-07 at 09.14.05

Although sending it alone seems to work fine… I’ll have to look into this further :man_facepalming:

1 Like

Well the help with all this is really appreciated ! I’m looking forward to the next update, do you know roughly what sort of timescale to expect? - let me know if there’s a beta available. Many thanks :smiley:

1 Like

Hi Alan, apologies if this is should be in a different thread - but I just thought I’d ask as I’m totally new to this and maybe its me doing something (or not) that’s pretty straight forward… I tried to enable a webhook on this stream but can’t get it send even though the triggers should have fired it - is there a simple reason for this?!

1 Like

Hey @mattm!

Sorry I missed your last message! Usually we do beta releases at the end of every sprint, which is every 2 weeks. We’re in the middle of one so, sometime next week/beguinning of the following week, depending on how things go with the features we’ve planned to include.

As for your webhooks question, i opened a new thread for it here: Webhook is not being called

Hi Alan, just wondered if there’s a beta release yet that addresses this issue we were having? many thanks

I had this problem too. Somehow, arcs/circles surfaces (i haven’t test all) from rhino scheme method weren’t able to model rvt floors.

Later, i had to rebuild the curves in straight segments to help speckle model rvt floors.

1 Like

Hi @Johan_Navarro_MA ,

This is a limitation on Revit’s end actually. Revit can’t create single closed splines. So you have to split these into two parts and send again. Take a look at the topic below👇:

Though maybe we can do some magic for circles because they should go pretty straightforward @AlanRynne

1 Like