Suddently cant receive -

  • Grasshopper Receive component:
    My Grasshopper Receive component fails to load streams. I am successfully logged in according to the “AccDet” component.

I’m getting below error:

1. One or more errors occurred.
    The graphql request failed without a graphql response
    Policy Failed
    An error occurred while sending the request.
    The underlying connection was closed: An unexpected error occurred on a receive.
    The client and server cannot communicate, because they do not possess a common algorithm

This is with a private server hosted at
Same happens with various streams.

The entire setup worked fine 2 days ago.

with the debugger attached, im getting the exception here:

Same stream works fine with the Rhino Connector.

EDIT: Seems like a Restart of Rhino solved it …

Piggiebacking on Mathias’s post since i got the same error again just now and it looked very familiar. This seems to be related to the stream fetch errors in the Rhino / Archicad connectors i’ve ran into a while ago and reported here:

After getting the error in GH tried receiving in Rhino and noticed that the Rhino connector was also unable to retreive any data:



Hey guys, we’re looking into this - will keep you posted!

If you have any chance, could you please verify you experience the same issues when being connected to a different network?
Could you please also check if reverting to the latest stable version of the connectors the issue persists?

@Andrei did this work for you too?

Yes this worked yesterday, but only after all other rhino instances i had opened closed down. This was when i was on the office network connected via docking station. Today via wireless VPN at home, restart didnt work unless i run Rhino with admin rights.

1 Like