Speckle Connector unable to locate streams / authenticate account?

Since 2.16, and now 2.17 we’ve been having some issues with streams/ account info not showing up in the connector UI, making it impossible to send or receive anything. Most noticable in Rhino / grasshopper ( probably because those are the connectors we use the mosts), allthough i do remember something similar happening in Archicad on one occasion. UI will look something like this:

Notice the Account button that should be in the top right of the window fails to display entirely, so i can’t even check if the authentification went through. Addin by ID or url will give stream not found errors. I’ve had several coworkers encounter this including myself, and the only solution we found was to update the connectors or reinstall manager.

Edit: Additional info: The accounts button is actually there but the icon is gone. Account info displays correctly, shows as logged in. A fix i managed to work out now is running rhino as admin, then everythings works as normal, including the icon in the UI. But starting it withotu admin on this particular machine will not fetch any stream info. On my computer however, works fine without admin rights for either rhino or manager. Very strange!

Hey @Andrei ,

Sorry to hear about this - note that you can always roll back to previous versions via Manager if needed.

Could you please share via DM the logs from a computer where the issue is being reproduced?
You can find them in %appdata%\Speckle\Logs\

To pick up on @teocomi’s question, are you installing connectors using Manager or from the releases.speckle.systems ?

Hi @Andrei

We’re discussing this, this AM, and have a couple of questions in addition to Jonathon’s, a few more may also appear as we investigate…

On the machine where you’re not having these issues? I’d like to check a few things:

  • The logged in user is definitely not also an admin on that machine?
  • Is the machine on the same physical network as the machine where Admin only works? Or is it working on or off VPN?
  • Does your organisation employ group policy to hardware and users and is this applied the same across both machines?
  • And also Jonathon’s question - are you installing connectors using Manager or from the releases.speckle.systems
  • Can you also confirm the exact version of the Connectors you’re using? Have you moved to the 2.17 release version yet?

We’ve had a brief look here and are not able to reproduce, but we will also be looking over logs so may have some questions.

Thanks in advance
Ian H


Users do not have admin priviledges unless specifically asking for them via an app, and then it is only temporary, the admin permissions switching off after 30mins max. In both cases, me and the user i was helping with speckle, none of us had admin priviledges at the time. And got different results.

Machines were on the same physical network. However, today i am working from home, and i am connecting via VPN, and when opening speckle in a new rhino instance i get the issue>

However, in the Rhino isntance i started yday while i was in the office, the speckle UI still works fine and i see all streams and can send receive as normal. So even on the same machine, seems like different results can occur.

I am using the 2.17 rc3 version of the connector while the other user was on the latest release 2.17.0. The connectors are always installed through the manager. The issue first started popping up on version 2.16 or 2.16.3 if i remember correctly. My most recent log file>
SpeckleCoreLog20231206.txt (547.9 KB)


Thanks @Andrei

When you connected in the office and it worked fine, was this Wirelessly or wired? Is the machine that works only as Admin wired or wireless?

Ian H

Wired while at the office. So both me ( working fine ) and the other user ( no streams found) were plugged in via docking stations. I am now on wireless conencting via VPN while at home, and gettin the no streams found errors on new rhino instances unless i start with admin priviledges. Then it works.

Thanks for the prompt reply!

What we can see is that it isn’t possible to negotiate a secure connection with the server so the connection fails, hence you don’t see any streams.

Given the investigation to date, it is possible that something environmental, the networking of your org, is having an impact on creating this secure connection.

Would you be able to inquire of your IT department whether there is any limiting of networking when connected to the corporate network and not running as Admin? We are particularly interested in any Group Policy settings that deny TLS versions or specific Ciphers used by TLS handshaking. We would also be keen to confirm whether there’s any re-writing of certificates that may be presenting your server slightly differently when on the corporate network.

Given you were docked and wired and working and the other user was docked and wired and not working. It would be useful to know, if the other user undocks, restarts and connects outside of the corporate network, ,whether this works or not? Equally, is possible, if you shutdown and swap docks of network cables whether you are similarly restricted when he connects.

Apologies for asking so many questions, but it does feel like an environmental issue and these can be quite tricky to ping down.

We are continuing some investigation on our end also.

Ian H


Currently Checking on your questions but the whole thing seems very inconsistent and almost completely random. Tried a bunch more things here now:

So started rhino via VPN ( need the Zoo server license) then disconnected from the VPN and started Speckle. Everything worked. Closed Rhino.

Reconnected to the VPN. Started Rhino again, and started Speckle while still on the VPN. Now it works somehow. Didnt have to do any admin permissions or anything. Very strange… I can no longer replicate the error that i could replicate 100% of the time 2 hours ago.

About the TLS , we are following microsoft standards and TLS 1.1 was flagged to stopped used many months ago. I will have to set up a meeting with our external IT service provider in order to find out more details retarding ciphers TLS handshaking etc.

This is good news in a way. :partying_face: But a frustrating one :cry:

If you experience the same issue again, let us know as soon as possible at your convenience. We can jump on a call if needed and try and catch the gremlin in the act. (might need aligning with your IT provider)

As @ianh was hinting, we’ve had a detailed look at what has changed in the Connectors during the time span you have reported problems, and if anything, we have made some security changes according to best practices around TLS.

Keep in touch, and now things are working for you - happy Speckling!