SpeckleException ("Could not get the requested stream")

Hi everyone, I have some issues between stream exchange speckle-blender.
Blender doesnt see open streams og doesnt recognize when add new one.
Instead provides this error message. Any ideas?

blender version is 3.4.1
speckle/blender connection 2.12.2
windows 10 x64

Hi @Tymofii
Does this error still occur after pressing the refresh button?

I have reinstalled app many times already and reinstalled both blender and all plugins I intended.
What I figured out is that I cant install it properly, it shows error message each time.
Further, I have removed my account and created new. What I see is that speckle manager shows no authorized apps, only speckle connector, no revit, no blender … Is there issue with speckle manager then?

upd. Looks like I found SpecleBlender 2,0 and it was normally installed.
samme issue, no stream and get this message

after refresh button

no stream

Please, could you let me know if you are able to use other connectors file, or is it just the Blender connector.

Additionally, if you are using a VPN or corporate network/firewall/proxy. Some users have reported problems with this in the past.

Otherwise, please could you follow the steps to ensure the blender connector is properly installed.

  1. Uninstall the blender connector through Manager.
  2. Go to %appdata%/Blender Foundation\Blender\3.4\scripts\addons folder.
    (If you have other add-ons installed, you may want to create a backup of this folder or be prepared to reinstall all your plugins afterwards)
  3. Delete the contents of the addons folder.
  4. Install the blender connector through Speckle Manager.
  5. Ensure you have at least 1 account added in Speckle Manager. (under the accounts tab)
  6. Restart blender and enable the SpeckleBlender addon in preferences → add-ons

same here
im using it from corporate network, can it be the issue?

1 Like

I can confirm that this is internal security issue in my company.
I did same procedure on my friends pc who works in university and speckle/blender is working as it should.


You can point your IT people at this document: FAQs | Speckle Docs

If the server address is blocked by a corporate firewall, proxy or VPN, kindly ask your IT department to allowlist the following domains and subdomains that Speckle uses:

Hope this helps!

1 Like

I’ll see what I can do about ensuring a more meaningful error message gets thrown for this type of issue in our blender connector :sweat_smile:

1 Like

The issue is resolved. Thanks everyone for help.