Speckle with Blender 4.2 (alpha)

For me Speckle works on Mac.

As I read of the 2.19 WIP Connector, I updated too via Speckle Manager.
But as always,
Speckle does not reliable update all Blender installations.

It updated 4.1 to 2.19 but did not update my 4.2 Alpha Settings.
4.2 had still 2.18.1 Connector version.
I replaced the 4.2 bpy_speckle folder by the newer from 4.1
and that worked.

I have that problem since at least a year. Is that the normal behavior ?
Is the Manager told to ignore Blender Alphas and Betas ?

Blender 4.2 is in still in Alpha.

Our installers don’t install to versions of Blender that we haven’t gone through our internal testing process, and generally we don’t do this until the Blender Foundation considers it a release candidate or a stable release.

You can manually install the Blender connector via the manual zip installer at https://releases.speckle.systems
you can install to any blender version this way including 4.2.

If you do get 4.2 to work, please let us know and/or report any bugs or problems to us!

Thank you.
OK, so this is a WAD.
So I know I have to care about updating Speckle manually by myself.

Usually I have a latest Blender official and always 1-2 latest Alphas and Betas
installed to test.
And as I so far do not do any serious in Blender, I usually open the Alpha only
for testing and learning. So I also mostly only test Speckle in Blender Alphas.

I can already say that I can’t remember any Speckle Connector issues just
because of Blender Alphas.

Same for Speckle and BlenderBIM AddOns.
My problem was always installation or better activation only.
But when activation succeeded, they worked as expected.