Blender Connector Fails to load

Hi all,

I’m having an error while loading the Blender plugin, please see attached screenshot.
I found a similar thread on the forum and tried already all the suggested solutions with no luck (uninstalling all the communityplugins, including Speckle, restart, install the speckle connector again etc…)
so far no luck :frowning:
I’m using Blender 4.01 and the 2.19.0 Speckle connector on Windows 11. I’m having the same problem on another computer at work, where I also tried to install the latest version of Blender and all the alpha release of the Speckle connectors.
Any help would be much appreciated :slight_smile:

Thank you!


Hi @palbo

For the first launch of the connector, you must be connected to the internet.
Our connector pulls dependencies from the Python Package Index (PyPI) on first launch.

Some other users have reported that company VPNs or Networks may block PyPI. Please try disabling your VPN or using a different network for the first launch.

Please let me know if that works (or not) for you

1 Like

Hi Jedd,
Thanks for the quick reply. I tried different internet connections, but it didn’t solve the problem.
I updated to Blender 4.1 + Speckle 2.91.0-wip1 though and it’s all working now. It might have been a compatibility issue between software versions?
Thanks again!


1 Like

3 posts were split to a new topic: Speckle with Blender 4.2 (alpha)

What version of Speckle did you try before? (the one that didn’t work)