Speckle not working in Dynamo 2.6

Unable to use Sender or Receiver and the Nodes look all weird. Uninstalled/Renistalled and Restarted Revit/Dynamo. Looks the same. Also no longer able to connect to our own server.

Looks like a conflict with another package / library.
Can you please share a screenshot of other installed packages?

Also, what version of Dynamo is it?


Thanks for the screenshots! I can’t spot any specific issues right away…
I’d suggest to:

  • close Dynamo
  • temporarily disable all other packages, you can do so by manually moving them away from their current location, which should be %appdata%\Dynamo\Dynamo Revit\2.6\packages
  • reopen Dynamo and see if Speckle works

If it does, you can then re-enable the other packages one by one to find which one is conflicting…

Uninstalled an “add-in” mentioned in the notification, also moved all other packages out. Still no luck.

Hey @Magneg,

Thanks for holding on :smiley:, I installed the Generative Design plugin and still can’t reproduce your issue…
The only last thing I can think of is a conflict with a Revit addin. Have you installed any new addins recently?

If you have the time to disable them we can try find out what’s going on…

I just noticed your Dynamo is missing the Speckle menu:


It could be that something is wrong with your installation too, have you run the latest installer?

Hi. Uninstalled 1.7 and installed the 1.8.31. Now i have the add-in for Revit but nothing in Dynamo. This is so strange.

Found it under Dynamo 2.5, copied it to 2.6. Still no Speckle-menu and the nodes are not correct.

Cleaned up all “Speckle for Dynamo” in all Dynamo versions. Then Reinstalled. To me it just looks like Dynamo 2.6 is not supported.

How did you get Dynamo 2.6 in Revit? With 2021 I’m stuck at 2.5…

Although while using Dynamo sandbox, Speckle works fine up to v2.8:


It does work with Sandbox v2.7. But it doesn’t really help me with Revit and Dynamo v2.6.

That’s unfortunate! I’ll try to update my Revit via the latest service pack, I guess that will install 2.6 with it and will let you know.

In the meantime, you could try asking a colleague, or try with a clean machine to see if the issue can be reproduced there.

Another option could be to downgrade your dynamo version, if possible.


Got this test from a collegue. Sadly there is something not right at my PC…

Thanks for the update! It sucks you can’t get it working on your PC…
I’m a bit short of ideas here (a part from nuking Revit and installing it again).

Hopefully the new 2.0 release will run without hiccups!