Speckle Compute Units Help

Hi all,

I am posting this again because I did not get a reply on my previous post almost a month back. I am really trying to fix this issue for our web app and the speckle functionality has been totally unusable without this fix.

I am trying to automate Rhino conversion to Revit through compute using a grasshopper script but the output geometry is in mm and not in metres as I require for Revit. Commit

I have tried putting a python script in my gh script to create a headless doc with meters as default units but it doesnt work.
image

Thanks

Hey @Rivindu_Bandara sorry we missed you other post!
I’m not sure I understand how you’ve set up things, but have you tried changing units in your grasshopper/rhino environment?

So this is a grasshopper script running on rhino compute. It pushes some geometry to a speckle stream. I have created a python component that has a headless doc and set the units to meters. But the output geometry is still in millimetres. You can see from the link to this commit for example. Speckle

I think that Speckle might not be able to properly get units form the document when inside Rhino Compute… Adding @AlanRynne who might have some more ideas.

1 Like