Speckle Archicad not installing

Hi,

I know archicad is still in alpha… but I wanted to check speckle out since our office uses archicad and the capability of Speckle is very impressive. My only issue is that I can’t seem to install Speckle’s connector to archicad. I have gone through using Speckle Manager (v2.2.2-beta) and manually installing the archicad connector to no avail. I’m also using Archicad 25 and an admin for this computer.

Thanks… if there’s anything I missed to inform please tell me. I’m very keen to test speckle out further.

edit:
So I also tried activating it through the add on manager in archicad, however it says, “This add-on cannot be validated. Please contact the distributor.”

Hi,

I have the same issue. I would really appriciate a solution too.

hey @jack-fp and @reka ,

sorry about that! I think I’ve figured out the issue and should be able to put out a new installer within the next couple of days. in the meantime, you could try starting archicad in DEMO mode (run 'C:/Program Files/GRAPHISOFT/ARCHICAD 25/ARCHICAD.exe' -DEMO from the command line) which should allow you to at least play around with the connector.

Hey Thanks for your reply, Everything seemed to be running as it should but I can’t seem to open the speckle window.

Got Archicad running in demo mode, and the add-on manager didn’t have the :warning: icon on speckle. However, I couldn’t seem to open the connector. Not sure why… but I’ll probably wait for the next version of it.

Thanks.

edit: @izzylys I was wondering if the reason mine doesn’t work is because the archicad 25 version I’m using is different to what has been tested on. I’m using 5010. Not sure if that makes a difference…

1 Like

hello again @jack-fp and @reka,

I believe I’ve been able to fix the issue with the connector not loading in regular mode - could you please try the latest version v2.5.2 and see if this has resolved the issue for you?

@jack-fp I don’t believe the minor version should affect the compatibility of the connector, but if 2.5.2 still doesn’t work for you I can investigate to see if there were any API changes that could possibly be interfering

2 Likes

Hi @izzylys ,

Thanks for the quick reply. I’ve installed the new version, it looks good now, and I can see the Speckle Connector in the Interoperability menu, but the window does not launch, when I click on it.

2 Likes

Hello again!

sooo… here’s my report. I installed v2.5.2 and had the same results as @reka. Speckle shows in the interoperability menu but does not open.

so close

3 Likes

Hey both, thanks for testing the alpha connector and for your patience so far, there are many unknowns when rolling out a brand new connector and your help is essential :slight_smile:

We’ll look into this asap, although because of internal planning and time off it might take a couple of weeks - stay tuned!

2 Likes