Send Error in Rhino

Hi guys, having a frustrating issue in our office, seems to be localised to just my machine.

Getting the following error:
“Send Error!
System.Collections.Generic.KeyNotFoundException - The given key was not present in the dictionary.”

I’ve tried all the easy fixes, reinstalling speckle, reinstalling rhino, restarting the machine, with no luck.

Anyone had this problem and know of a fix?

Any help is much appreciated!

Do you have other connectors installed for other software? Are the versions in sync for each?

Which version of Rhino and which version of the Speckle connector?

Hi Jonathon,

Using Rhino 7.3.6 and Speckle v2.13.0, both have been updated.
I do have the connector installed for revit and autocad, I’ve done a test to send info from Revit and works fine.

2.13 sounds like the version of Speckle Manager unless you are VERY out of date.

I’m screenshotting my Manager, which shows I’m in a dangerous state as the connectors are at different versions - this happens as we are testing new releases. For an ideal experience, get each of the Revit, AutoCAD and Rhino connectors at 2.18 if they aren’t already

Thanks Jonathon, this worked!
I had an AutoCAD connector that was out of date.

1 Like