Selected Geometry is hidden, stopeed sending

Hi everyone!

  • Objective:
    I am trying to upload Navisworks model (Federated Civil3D model)
    Size of NWD is less than 3 mb
  • Issue:
    When I try to upload I got message, that selected geometry is hidden and sending stopped.
    On screeshot

Attached screenshot

Would you be able to share that model with me? That error shouldn’t report for that selection mode for sure.

Hey @AlexP,

I have isolated the issue causing this - working on a hotfix right now.

1 Like

HI @jonathon,
I try new version 2.15.1
but the same problem

Here is the NWD model
Pankin Aleksandr - Road with QTO+Timeliner 2023.08.31.nwd (2.6 MB)

1 Like

Thanks. I’ll see what’s up in my tomorrow

@AlexP I have been unable to reproduce your issue with the file you provided.

I have used the selection method you showed originally Item > Guid > not equal to > 0

I have also downgraded to 2.15.0 and could not replicate that either.

I have tested with both Manage 2022 and Manage 2024. Are you using Simulate?

Do you have other ADSK/Rhino Speckle plugins installed with different versions?


@jonathon thank you I will try another PC
I have installed only Navis and Civil3D

I am using Manage 2022/

1 Like

Hi again,

I’ve install Navisworks 2024 version on clear System, but faced with the same problem.
The query is the same “Element GUID != 0”.

@jonathon could you help me please?

Still the same file?

I tried lots of different factors and couldn’t replicate.

I will check again. There’s no reason I can think of that localised language should cause this but I’ll explore that.

1 Like

Hi @jonathon!

I solved it.
The problem was with the localization of Navisworks.


That is an excellent discovery. I’ll dig into making things language neutral!

Internationalisation is a medium term mission for us, but that is for UI, it shouldn’t affect core functionality.

1 Like

I have added a fix that should come out in the next release.