Revit "Sentry.Internal..." error

Hi everyone! While I do not receive an error in Revit 2023, I receive such an error in Revit 2024. Would you help me with this topic ?

Hey, seems the same issue reported here: Revit Connector not starting Sentry error

Hi, I have the same problem and I looked att the linked issue that you posted. There is only sentry.dll from Speckle Revit addon on my pc. Can it be the problem with admin rights in Windows?

Hi @audrius

When you say “There is only sentry.dll from Speckle Revit addon on my pc”, can I confirm that in searching your PC this is the only one sentry DLL you can find?

Apologies if I missed this, but can you confirm Speckle versions you are using? Which version of Speckle did you start with?

Thanks in advance
Ian H

Speaking for myself, yes, there is only Speckle Sentry.dll, but I still cannot run it.

yes, it are only sentry.dll files that are in Speckle addon folders and some in temp folder (I think these files are from installation). I am using Revit connector 2.17 and speckle manager version is 2.12.2.



1 Like

Hey, I am using Revit 24 and also installed Speckle.
I worked for a while an now I get the following error message.
Anyone familiar with this?

Hi Myriam,

This is most certainly due to a conflict with another Revit/Dynamo plugin. You can try disabling them one by one or searching if any of them uses a DLL called sentry.

Thank’s for your reply. I actually can’t figure out what’s wrong with my speckle. Can’t find any ‘sentry’.
I even installed everything new now. Not good with computerstuff :wink:

No worries, let’s see!
Try to search in these folders on your machine for a file containing sentry in its name.
That should give us some more indicators:

(You can copy/paste the paths in windows explorer, and adjust the Revit year where needed)

C:\Program Files\Autodesk\Revit 20XX\AddIns\

Hey Matteo,

found some here. Which one is THE ONE? :smiley:

If you could expand the path column a bit more to show the exact location; then we might be able to suggest a few that might need disabling…

Does this help? Thanks so much for your help. I’d be totally lost without your support.

Hi @Myriam_Hartig

Thanks for the screenshot, that’s helpful.

What we could really do with is that same search you did but seeing the full path to each of those Sentry files. Having completed the search, can you change the view to Detail and expand the folder, file name columns so we can see the install location, size and file names, please?

This might help us identify any possible conflicting versions.

If you need help with any of the above then let me know.

Ian H

Thanks for these details, we are looking into these reports. Do you have another version of Revit to test? So far the reports are all out of 2024, but we cannot reproduce at present.

Thanks for @audrius, @erayalkan and @Myriam_Hartig for your patience as we delve deeper.

Here is the search for Revit 2023. Dones’t work with this version as well.

Thanks for testing @Myriam_Hartig. Are you behind a firewall, corporate networks, VPN or is this a personal PC?

It is a work PC. The thing is, it worked before and doesn’t anymore. And, it works on my boss’ PC. There is an VPN but it doesn’t make a difference if I am connected oder not. Doesn’t work with both settings.

1 Like

Ok. Is the other PC where everything is working using the same version of Speckle Connector? Did the change happen after an upgrade of Speckle Connector OR an update to Revit itself or any other plugins?

If something has worked before and now doesn’t - this is really helpful information to work out if we can get to the cause.

I have the same issue on Revit 2021,2023 and 2024.