Revit Cannot run the external application "Speckle 2 for Revit"

Hello all,
Just updated to the 2.19 Release and received error below any insight on what’s wrong and what I need to do to fix it. I haven’t been able to use Speckle for a few weeks now was hoping the latest release would fix the problem. Working in Revit 2023. No logs are produced.

Also getting this
image

Hi @B.Kaiser,

This looks like a .dll conflict. This means another plug-in conflict with Speckle. Did you install lately a new plug-in?

Please have a look here at how to troubleshoot a .dll conflict FAQs | Speckle Docs

Yes I have working through it now i’ll update if it’s the cause.

@Nikos Disabled add in rebooted computer still won’t work. Any idea on the first part of the error underlined below? I don’t understand how the file patch can be too long.

Hey @B.Kaiser,

I’m sorry that you are still experiencing problems. We are also investigating from our side, as it’s an odd error - but we have some guesses of what is causing it. In the meantime and now that you have disabled the other add-in, can you try downgrading to version 2.18.4 and try again?

Let me know how it goes,
Thank you

@Nikos Re installed 2.18.4 didn’t get the error when loading Revit this time when when I try to preform a data exchange I had a “remote transport failed” notification at the bottom of the tool pallet . See attached log file let me know what I can do to help.
SpeckleCoreLog20240527.txt (50.9 KB)

Hey @B.Kaiser ,

Sorry about the bad experience so far. Would you be able to share the model with us so we can debug further? Happy to sign an NDA if needed.

You can drop it in this secure folder: https://drive.google.com/drive/folders/1LYvpMiDtTKRQ-NKfV3Bc_fhmUFiPLO56?usp=drive_link

The issue is probably the same you raised here: Revit 2023 remote transport failed

@teocomi the experience has been great so far just not working at the moment! I’m sure is something on my end but hope the access to the model will help, I’ve uploaded it to the link you provided.

1 Like

We have received reports of large files failing to upload, so for now, while we test things, I can recommend trying to publish only portions of it, if possible.

Thanks!

Thanks @teocomi. I have been splitting by floor using 3D view exports, separating mechanical, electrical, structural, and architectural elements. This workflow has been preferred for what I do and has worked fine until now. I hope you guys will find a solution for this as it has been a great tool so far.

1 Like

@teocomi have you guys had any luck with my model? I just updated today to the latest build but still getting errors. The line that’s highlighted “The path is not of legal form” what is that referencing?

Hey @B.Kaiser ,

We’re investigating the issue sending large files, thanks for sharing the model with us.
It’s something that touches both connectors and server and will take us a bit to solve.

In regards to this specific error message, we think it’s due to a conflict with some other Revit/Dynamo plugin. Not sure if you already tried, but you could disable other plugins until we find the culprit.

Some guidance here: FAQs | Speckle Docs

@teocomi also getting a error when opening Revit in any year “The path is not of a legal form” any ideas on that ?
image