Receiving ETABS element force data in Revit

I just analyzed a model in Etabs sent it to Revit, but element forces area zero. How can I solve that ?

Does anybody have a solution ?

I have flagged it with the team. However many of whom are taking a deserved breather after SpeckleCon.

Can you confirm which version of the ETABs and Revit Connectors you have installed?

We are reaching the stable 2.17 soon, but you can try it out already if in Manager you select “Show experimental versions”

2.17-rc3 is latest I believe.

1 Like

I’m using 2.16.3 version.

I suppose speckle couldn’t detect analysis results (moment, shear, …) to export them.

Do try 2.17 - ETABs REVIT was a point of focus so it maybe in the features picked up (but I don’t have the changelog to hand)

1 Like

Ok. I will try it.
Thanks Jonathon :pray:

I tested 2.17 version.
I noticed there are new options to export analysis results from Etabs and I chose my required loads (not show in this pic) :

then I imported this model to Revit using 2.17 version. but I couldn’t member forces in Revit:

Hi @Farzan_Bayat, receiving analytical results is not yet supported in Revit but thanks for giving our latest release a go. You can receive the results to Excel if that helps.

How would you work with the results in Revit? Could you tell me more about your use case?

Hi @Pavol
Sure, I will explain about my use case.
There is an option for connection families, named Range of applicability :

What happens here is that you apply connections to members based on the force amount.
For Example if shear force is less than 100 ton, use family type “A” and if shear is more that 100 ton, use family type “B”

Using this feature, You can quickly assign connections based on the analysis results which are obtained from Etabs.

1 Like

Can I hope that this feature become available in the next update ?

@Farzan_Bayat we try our best to add this feature in near future but I can’t give you any time frame at this point. Stay tuned :slight_smile:


Ok @Pavol
I appreciate your efforts.
I’ll stay tuned.

1 Like