QGIS to SketchUp : Issue with geometry insertion point

Hey Team,

I am finding that data from QGIS in not importing in the expected location in SketchUp. I am not sure if this is a PEBCAK :wink: , SketchUp, or Speckle.

See the graphics and or the attached pdf for enhance details but in short…
1) I am using the “Set Project Center” feature in Speckle-QGIS. When importing into SketchUp, it looks to be inserted in the wrong location.

QGIS to SketchUp _ Placement Issue.pdf (9.7 MB)

2) I have also found that the “branch” component has an axis origin that is located relatively far from the geometry. I would expect it to be located at the Project Center as well.

Any tips or comments would be helpful



Hey @ChrisD,

Thank you so much for reporting the issue and providing such a great document! :slight_smile:
We’ve logged this issue and will try to reproduce and fix it ASAP.


Hi @ChrisD,

I tried to reproduce the issue you reported but I was not able to do so. @Kateryna sent a file from QGIS which had the center point located in the courtyard of the building. When I received this file in Sketchup, the origin was still located in the courtyard as intended.

Can you please share the Speckle Model URL with us? Also, if you could share the QGIS file, it would help us with debugging.

By the way, I noticed your other comment about the component origin. That is a great catch!


Here is the footprint commit

Here is the centroid I created through QGIS. This was used for the project center calculation
speckle_centroid.zip (2.4 KB)

My apologies if it turns out that this was user error at some point in the process.
Please let me know if there is a missed or incorrect step in the process so I can properly document it for future implementations.



Hey, thanks for the files! Unfortunately these are just separate shapefiles, it would really help if you could share the QGIS project. I sent the data after dragging it to the new QGIS project, the center point in a CAD software after receiving seems correct:

Nevertheless, I noticed that while applying the custom CRS, QGIS gives the warning like this:

Do you receive the same warning? It basically means that the two systems are based on different ellipsoids (the layer CRS - NAD83, and WGS84 the project is being converted to) and the standard conversions might not work perfectly - additional datum conversions might be required to avoid ~1m precision issues. Here or here are more details: :

Nevertheless, I couldn’t reproduce by just dragging the shapefiles on an empty canvas. Moreover, I received your commit and it fits perfectly in the correct geographic location! I also noticed that the coordinates you specified in the commit message are not the same as the ones in the new CRS settings. I created a new CRS with those values (latitude of origin and central meridian) and that point is indeed located on the surface of the building, so the CRS was created correctly. Pls try creating it again with the exact numbers and see if you encounter the same error :pray: