Receiving QGIS Vector/Raster Layers in SketchUp


I see that Extrude by Attribute feature has been added. Wonderful!!

Problem: I am getting a “Failed to convert” message through SketchUp’s API dialog when trying to import any geometery (lines, polygons, 3D extrusions).


name: receive_objects
Failed to convert Speckle.Core.Models.Collection:Objects.GIS.VectorLayer (id: f064476a2c48ed0f835ba3118c021ab3)
undefined method `call’ for nil:NilClass
==== Converting to Native executed in 0.005 sec ====
==== Source application is QGIS3. ====

I am using the Mac version of Speckle for SketchUp.

1 Like

Hi @ChrisD,

Thank you for reporting! And good to hear people already started to use Speckle SketchUp on Mac! :green_apple:

Currently, we do not have support for Speckle.Core.Models.Collection:Objects.GIS.VectorLayer object on SketchUp. I’ll investigate more and get back to you!


Perhaps it is not the same vector support as in post Qgis polygon data to Sketchup.

Would love to hear what you find


Here is the project stream url that I am working with

Hi @ChrisD ! We have tested the commit with @oguzhankoral and made the fixes, so this exchange should be smooth in QGIS 2.17.0 and SketchUp 2.17.2

But there are 2 questions.

  1. When I received this commit, it seems to be placed wrongly. The layer has EPSG:26986 - NAD83 / Massachusetts Mainland, and it might be the error in QGIS CRS conversions itself (I received a warning) but it seems too far for a conversion error. Is it possible for you to share an original file? I’m trying to understand if it’s the original data location, or something went wrong during Speckle conversions.

  2. If you send the data as is, keeping the EPSG:26986 - NAD83 / Massachusetts Mainland CRS, it might be tricky to receive it in SketchUp at the moment, as it is too far away from origin. We want to look closer at aligning QGIS and SketchUp coordinate systems at some point, so it can automatically re-center the data on Receive. But for now, it might need to be re-centered in advance in QGIS. There are 2 options:

  • If you want to keep the projection EPSG:26986, you can click Set project center, and use option “Add offsets/rotation”. Add there the current coordinates (in linear units) of your desired center point. Make sure you place them in a correct order (e.g. x-value goes to Lon, y-value goes to Lat):

  • If you don’t need to preserve a specific CRS, you can choose “Create custom CRS”. Right-click on the canvas to get the coordinates (in degrees) and create a custom CRS based on them. Then, even on QGIS canvas you will see that the origin point is somewhere in the middle of your model:

1 Like

Here are the various shp files I used in QGIS (3.1 MB)

Thanks for the help

I will look at your export workflows.



First… again thank you for your assistance. Using the “Add offsets/rotation” option does provide a lot of control and the SU geometry came in. Thanks for the quick fix.

I love how the indidual footprints have come into SU as separate components and I discovered that the shp attributes come over as well!! Smart move!

:+1: :+1: :+1: :+1:

There were some issues I experienced that may be related to how components are created.
I will do some investigations and will PM you some more detailed findings.

To help those who are going to look at the “Add offsets/rotation” option…
Issue found - “Add offsets/rotation”

There may be an issue with how components are create. After import conversion is completed, the footprints appeared at first to be fine but when zooming, visual errors are exposed. Note how the footprint experience visual culling.
When selecting them, you can see how each component has a ghostly brother.

I have found a fast fix using the Axis Tools extension which essentially re-seats each component’s axis/origin. After using the extension, all works fine :slight_smile:


1 Like

Hi @ChrisD,

This feedback is important. I’ll create a ticket to address it in the next release. Thanks for sharing with us the fix you found!


For the “Add offsets/rotation” workflow, after the import, simply save > close > re-open the SketchUp file. It looks like SketchUp’s validation check could be correcting the culling / transformation issues mentioned above. :slight_smile: