Problem uploading IFC to Speckle, it doesn't load the file

Hello, I am trying to upload more IFC to one project on Speckle. The problem is that the importing never ends and is stuck from more than one day. I have already deleted the project (is not possible directly the IFC when it’s uploading) and trying again occurs the same problem.
What can I do?
speckle

Hi @alez91 - thanks for reporting this issue. Sorry this experience hasn’t been as straightforward as we’d like it to be.

Can you confirm the domain you are using to access Speckle, is it app.speckle.systems, speckle.xyz, or something else?

Assuming you were using app.speckle.systems I tried searching for the filename in the screenshot, but could not find it. Can you copy the exact filename as text here? I may have made an error while trying to determine the exact filename.

Would you be able to also copy here the url for the model as it appears in your browser? (This will give me the project ID and the model ID).

However, if it’s a self-hosted server to which you (or a colleague) has admin access; you can look in the logs of the fileimport-service container as it may have generated additional information that hasn’t been conveyed to the UI.

Iain

1 Like

Hi @iainsproat , thanks for your reply!
Yes I am using the domain app.speckle.systems
The file of the name that I am actually trying to load is:
B-C-11006BX-C-CV-001.ifc
The url of the project is:
app.speckle.systems/projects/049a3d5560/models/2bf7f4c8c6,all
Let me know if you can find it and what I can do to solve this problem please, the size is not too high (99MB) so I don’t think this is the problem.

Many thanks
Alessandro

1 Like

Thanks, can you please retry?

I expect it to again fail, but I’ll use the retry to gather some extra data in our system to help debug this.

Iain

Thanks for helping, I think that another problem is that when an IFC is uploading there is no option to stop it and remove the loading, as you can see in the picture.

Is the only way to cancel the entire project and start a new one?

Alessandro

Did you retry uploading the file?

Unfortunately there’s a known bug in the UI, where the loading spinner continues to be shown even when the process has failed in the server. It is no longer being processed, so the loading spinner can be ignored.

Iain

Yes I tried again with a file of 75Mb but still is loading in loop, I don’t really know what to do, in this condition is quite difficult to build a federated model to be connected through Speckle to another software. :pensive:
What can we do more?

Sorry, this issue has persisted for you. I have shared a secure Dropbox with you (to your forum email) if you could upload the file that is causing you difficulty.

There is nothing we can clearly diagnose without the problem file.

Hello Jonathon, I have loaded the IFC on the Drive link you sent to me. Let me know if you find out something, otherwise I cannot proceed using Speckle with a model completed.
Many thanks!

I have imported to our latest development server without issue. The conversion did take approximately 7 minutes, but completed, seemingly without error: