Power BI - Unable to Connect

As a beginner in Power BI , above is a simple chart I created using Speckle. :tada::tada:


I’ve installed version 0.0.7 of the Power BI connector, and I get this with my own streams, but can connect to a stream created by someone else.

I’ve tried creating two public streams, each from a separate (and very simple) Revit model. The streams looks OK in the browser. If I try to connect to them in Power BI I get “you are not authorized”.

Someone else in my organisation can connect to my stream using the same URL, and I can connect to their stream using their URL, I just can’t connect to my own streams!

An example stream that I’m unable to connect to is: Stream | Speckle (arup.com)

1 Like

Hi @colin.magner!

Welcome to the community! Feel free to Introduce yourself 🙆 if you haven’t already! :wink:

I tried reproducing the issue in my computer but everything seems to be working fine. I can:

  • Fetch the example stream you provided with no issues (thx for sharing it)
  • Fetch my own created streams anonymously and using a token
  • Fetch streams that are public anonymously and using a token

It occurs to me that it may have something to do with your credential settings in PowerBI

Then clear any existing entries referring to Speckle from the window that will pop up.

This will force PowerBI to re-request your credential strategy the next time you fetch data. I suggest you try both:

  • Accessing the data without providing a token (the Public Stream option).
  • Accessing the data by providing a token (the Private Stream option).

Since auth tokens do expire (@dimitrie please correct me on this one?), make sure you create a new token when you try this.

Let us know how it goes! :+1:t3:


Hey @colin.magner , since you’re on the Arup server it might be worth trying with ours as well to at least remove that variable: https://speckle.xyz/

Thanks for the suggestions Alan, Tecocomi.

Working on the Arup v2 server, after clearing the source settings:

  • The public option still gives me “you are not authorised”. I tried applying at all three levels (I assume normally you’d do this at the specific stream level).
  • The private option worked after generating a new personal token (set to “Streams:read”).

I created a new public stream with the same data on your server ( Stream | Speckle), and I can connect to this OK.

This is all very strange, as another colleague is able to connect to my stream with Power BI when it’s set to public, it’s just that I can’t! But I can connect to one of their public streams on our server.

1 Like

Hey @colin.magner, is the stream you provided still public? I can’t seem to access it anymore.

Not pointing any fingers here, but it seems like the problem may be on the Arup server? :thinking:

Just for clarification, you can set your credentials at the server level instead of “per-stream” and any streams you fetch will use the same credentials. Given your server is kind of private… I would just default to fetching everything with your token (public or private). I find this handier than setting the credentials on a “per-stream” basis.

Fetching any stream with a token will also provide the server with information on who is receiving the data. If you fetch it without a token, your commit’s won’t be tagged as received.

So I’d recommend, in general, using “Private Stream” option with your token and set it to the server url level.

Anyway, do let me know if the stream remains set to public, since i’m now getting “Your are not authorised” messages too! There may be some lurking bug that we need to look into!

Thanks Alan. The stream is still private, so it’s not a problem at your end!

Takeaways from this:

  • I’d prefer to use private streams rather than public, so using private and an access key by default sounds good.
  • I’ll find out who our server admin is and let them know about this anyhow, in case there’s an underlying issue that’s causing this behavior
  • You’ve also shown me how to reset the credentials for a Power BI source, so thanks for that!

Thanks again.



Resurrecting an old thread, as I’ve found new issues with connector version 0.0.7 and 0.0.6.

I get the following errors for both private and public streams (all on Arup server):


and if I use a specific commit I get this error:


This all works fine on version 0.0.5.

1 Like

Hi @Joe_Landers , before we dig into this, can you please tell us if you have the same issue on XYZ? Unfortunately, we cannot debug things on servers other than ours.


I just had a call with our internal Speckle team to discuss this, and prior to the meeting I got my streams loaded up and tested connecting them into Power BI… and they worked.

As far as we are all aware nothing has changed. We haven’t changed any Speckle server configuration (that those of us on the call are aware of), and I haven’t changed the Power BI connector (which is still 0.0.7) but I can now connect to both my public and private test streams.


Hi, managed to find some free time this evening to test this.

Yes, can confirm the same data on XYZ works and streams into PBI 0.0.5 and 0.0.7 connector (didn’t try 0.0.6).

But now 0.0.5 has stopped work on the Arup server. Very frustrating. @colin.magner did you have any more updates? I will make contact with our internal Speckle team to inquire.


Hi @Joe_Landers, I just tried and it’s still working. I honestly have no idea why it started working, and was unable to identify anything that changed in terms of software/configuration etc.

I’ve using the v0.0.7 connector, Power BI desktop 2.100.1182.0 64-bit (December 2021), and our v2 Speckle server.

1 Like

After Joe and I cleared our Speckle related data source settings, the PowerBI connector is able to receive again! I had the same issues as Joe. We are both using the James Bond (0.0.7) version.

Would it be an option to have the connector handle this automatically? Maybe first try to fetch the stream using any existing PowerBI data source settings and in a second attempt ignore any PowerBI data source settings?
(or maybe just a message in the “Unable to connect” pop up that the user could try to clear their data source settings via File > Options > Data source settings)

1 Like

Hi all! I’m trying to deal with with connecting data from speckle.xyz server to PowerBi using v0.0.7 connector. I think I’ve used all combinations listed above - the message remains - for commit and stream :confused:

Each time I remove Data source settings, but still with no luck

However, I haven’t tested the private link, because I don’t know from where should I get the activation token. Where shall I look for it?

1 Like

Hey @oliwer,

you can create new tokens from your profile page at the Speckle server (Speckle in this case). You can find out more about it here: Personal Access Tokens | Speckle Docs

We’ve recently changed the UI so the screenshots may be a little outdated, but its basically the same process. This is the section you’re looking for:

1 Like

It helped! Private stream does the trick. Thanks a million!

1 Like

Hey all,
I am waking up this thread, cause this happened to me today, but not with every stream…

Here is the stream:

It works when I give the link of a commit… but not of the stream itself… Of course, I want my data to be updated every time a new commit is uploaded… :slight_smile:

(Just as a temporary solution, how to switch the commit address to another one? To make a “manual” update of the data ?)

Thanks again for your great work Speckle Team !!!

1 Like

Hey @BaudouinNP :wave:,

This is the same issue @Mohamed_Elmasri had and it can be solved by adding your token to PowerBI. This is how you do:

  1. Go to you Profile on Speckle server. https://speckle.xyz/profile

  2. Under Developer Setting Create a New Token

  3. Set its name as PowerBI Connector and check every option under Scopes:ballot_box_with_check: and clickSAVE.


  4. This will create a token for you. Make sure you copied it. It is the first and last time you’ll be able to see this token. Treat it as a Password :lock: and do not share with anyone.

  5. Go to Power BI > Options and Settings > Data source settings.


  6. Go to Global Permissions and select your Speckle server.

  7. After selecting server, follow Edit Permissions > Edit > Private Stream. Paste your Token :1st_place_medal:into Personal Access Token input.


  8. That’s it. It should work now.

If you have trouble seeing your server under Data sources, simply delete existing servers. Go back to Speckle connector and try to receive the same stream/branch/commit. You’ll have the option to add it from there.

Normally you should be able to receive public streams without adding any token and this is a bug. We’ll fix this in the coming releases (hopefully).

Let me know if this helps.


A post was split to a new topic: PowerBI: How to change DataSource

:white_check_mark: This has been resolved with v0.0.12 of our PowerBI connector.

We have fixed this issue where users were not able to connect to public streams without a token. You can now connect to public streams without a token.

@BaudouinNP @oliwer @JdB @Joe_Landers