Polyline Sent from C3D To Revit Error

I’m trying to send profiles as 3D polylines from Civil 3D to Revit. When receiving in Revit, I am getting the following error. Any workaround to this?


1 Like

Hmm, can you share the Speckle Stream of the problematic model?

1 Like


Hey @Hamza_Tariq, Nothing wrong with your Civil3D data or the Speckle stream. This is a limitation on Revit.

You can bring real-world data into Revit by a few means. The simplest, in this case, is to set the coordinates of the Project Basepoint if you haven’t already.

Leaving the Survey Point at 0,0, you then can set the import reference point in Speckle options; you’ll find these under Advanced Settings:

And then select the Survey option.

I made up the Project basepoint from the coordinates in the Polyline you sent.

@jonathon Thanks for helping out. Could you please let me know from where did you see the coordinates in the polyline from stream?

The data that the polyline is encoded into is a string of coordinate points:

Using the relative to Survey method above, the same line start is:

I should say it was also important to know the units of these coordinates, my default in Revit metric is mm, and your data is in metres

It is still not working and Giving me the same error. Now when I try to set the units in revit to meter, then project base cannot be set and gives following error.

The way to set the Project Basepoint to real-world coordinates without getting this error is to use the Specify Coordinates At Point tool

The PBP doesn’t actually move relative to the internal origin of the model, but the Survey Point does. Somehow this doesn’t cause Revit to have a cow.

1 Like