Not able to use Revot connector

Hello everyone,
I am not able to make a data stream from Revit using Speckle
I tried the following
1- re installed the plug in
2- re installed the Speckle Manager
3- removed Dynamo connector
4- tried pre releases versions and older versions
5- re installed Revit
6- tried different Revit version

All the above could not solve the issue, please i need help

Thank you @Thulfiqar these edits to your original report any additional details make getting to the route case easier.

I also read your direct message but will keep updates here.

I’m sorry you didn’t get an immediate reply, we are a dedicated small team and will help as soon as we have information that may help.

After all these different steps, was the outcome always the same error details?

Yes Sir, it is the same error

1 Like

I’m looking into it now there’s a possibility some connection to our systems is blocked. Are you on a corporate IT network, behind firewall, using a VPN machine?

No, its personal PC and i have no firewall

1 Like

i turned off my firewall and i made both Speckle manager and Revit Run as Admin and same error

hey , just to let you know, i installed Revit and Speckle Manager on another device and used my accound and everything is working just fine, its not an account issue
what could be the issue ? that PC is my mian work station :melting_face:

1 Like

ok, the only thing i can see in the logs is manager unable to retrieve some of the feeds it expects, this shouldn’t affect the Revit Connector.

Another roll of the dice - could you remove you speckle account and then re-add it. You’ll need to do this from manager on the machine that is failing as the Speckle Connector isn’t loading

also do you have another application we have a connector for to try other than revit - just to see if it launches not to test any send/receives

I will try to do that and also will try the Naviswork connector as well

1 Like

i guess i found the issue but i dont know how to solve it, this is what i get in my accounts for Speckle and no matter how many times i delete it keeps coming again, even when i uninstall the manager and install it again the same thing happen

@Thulfiqar, something on that main PC is blocking or mutating our API calls. We cannot diagnose what this might be; it could be anywhere between you and our website, a firewall, a router issue, something on the network or something installed on the machine.

Did you try launching the Navisworks Connector, did you try exporting the Logs at %appdata%/Speckle/Logs ?

Repairing a broken Revit installation can be a pain. I’ve done this several times. It doesn’t need to relate to speckle.
I your a only using Revit it can be done with a clean uninstall. How to Complete a Clean Uninstall of Revit products
A regular uninstall doesn’t remove a lot off things.
Other Autodesk products might be an issue as well. Like Desktop Connector, License Manager or some other addons.