Not able to query Shared Parameters from Revit

Hi’

I’m having trouble querying shared parameters sent from Revit in the GraphQL interface.
The parameters are sent to Speckle, as I can see them in the data view.

Revit

Speckle Viewer

When querying OOTB parameters we normally use the applicationInternalName to query the parameter, but for shared parameters the shared parameter name is not transferred - only a GUID-like string is available.

When trying to query the shared parameter value using the GUID-like string we get an error.

I’m not sure if the cause is the connector not translating the shared parameter name to the applicationInternalName or if I should be able to use the GUID when querying.

The Stream can be accessed here:

Thanks.

Hi @martinromby ,

Sorry for the slow reply! We had to opt for using guids as the parameter names are not unique in Revit :frowning:

So I’m not sure why the call is failing… Maybe @gjedlicska or @dimitrie have some ideas…

1 Like

hey @martinromby,

I can reproduce this. Looks like having a - character in the parameter lookup borks the query. I’ll bring this up internally and let you know on what we can do.

Hey @martinromby

we’ve looked into this again, and currently there is a limitation on our end that makes querying parameters with - characters in their names not supported. Basically we’re passing the query over to our PostgreSQL database, that doesn’t support the - character in property queries.

As a workaround all i can think of is to receive the full parameters object via graphql and do the paramter lookup from the return data in your code.

Hope this helps :slight_smile:

2 Likes

Hey @gjedlicska

Thanks for getting back to me on this subject.
I did figure the workaround out myself, but thought that it was a bit unnecessary to fetch all of the data in parameters.
I guess this solution works for now. :slightly_smiling_face:

Yeah i figured so Martin :slight_smile: , i mainly wrote it down for prosperity.
And for anyone else looking for a solution for the same problem.

Until we get around to make this work properly :smiley: