Missing Elements from Revit while sending to Speckle


I have missing elements from sending data to Speckle as you see in attached pics.
I have tried to select elements and send it, then send everything at once, both give me the same result.

Can you help with this?


Pic from Speckle.

Pic from Revit.

We need your help to help you.

If you can, could you try the WIP release of Revit Connector 2.16?

We have been doing much work this release on picking up more elements. This is not a stable or even a release candidate version, but it might confirm if this is already something we are addressing.

If not, please share the model or a tiny model fragment with us.

Also, you could help us by describing the element and attaching the conversion log, which should say what has and hasn’t been converted.

Its okay , but how can I use this version ?

Then when you are done testing, you can install a previous Stable version (2.15.2)

Hi @jonathon

I tried this version and the total sent elements ware triple from the stable version, but the issue still same for sorry.

Any idea then !



:speckle: .

Sure, plz send me your email!

You can send us a direct message from the forum :slight_smile:
What is the type of the missing element?

Good Evening,

Sorry but the model is too funny to share :sweat_smile:

The missing elements is type of Structural Foundations.

I dont know why, but its like this…


We love funny models! Anyways, thanks we’ll try reproduce :slight_smile:

Hey @_Ahmed_Fuqaha I couldn’t reproduce the issue. I tested it with the sample Revit structural model and the latest 2.16 wip3 Connector and all Structural Foundations made it to Speckle. We would need that funny model to see if there is something funky. Just share it via direct message :slight_smile:

1 Like