Mapper - Topography mapping not working

Hi all.

I’m facing the same problem - in my case I can’t seem to get any mesh to come through into Revit as a toposurface!

I’ve followed the steps below - I used the example model @Sameer_Shah provided above and did the following:

Weld - using 360 as an angle tolerance

Then in Speckle Mapper assign to topography.

Sent to a new stream. I can see the topography in the Speckle viewer.

In Revit 2022, I then click Receive, and select the branch I sent the topography to.

In Revit, it states ‘received’ - but nothing appears. I’ve tried this with a small mesh I created in a new file as well.

Are there any other set up steps in Rhino and Revit that need to be performed?

Any help much appreciated!

Did the revit conversion log reveal more?

Can you share the project URL with us?

Hey @mattolsen ,

It seems that our conversion for mesh to Revit topography is not working as expected. @jonathon this is the error report shows:

Objects.Geometry.Mesh 827c84badbec20fc0a3c9e8165b2d4a0 Failed
Failed to convert due to unexpected error.
There are no points in the input points set.
Parameter name: points
Conversion to native Revit object failed. Retrying conversion with displayable geometry.
Object is not displayable (is not an instance, has no display value or it was null

We’ll look into it and get back to you once we have a fix. Thanks for reporting it.

1 Like

Brilliant, thanks for looking at this @gokermu! And yes exactly, on repeat tries I get the same error.

1 Like