Manager v2 Preview!

Hi @Testers and anyone else interested!

We’ve been working on a brand new version of Manager that should (:crossed_fingers: hopefully) resolve several issues that some of you were experiencing when installing new connectors. It’s been rewritten from scratch and we’re currently releasing it as a preview to gather early feedback (and bugs of course)!

So grab it while it’s hot and give it a spin, it can perfectly co-exist with the “old manager”.

:point_right: DOWNLOAD MANAGER V2

Currently, it’s Windows only, but soon enough it’ll be available for Mac a well.

manager

6 Likes

ohh this looks spiffy! I do like seeing the blog posts and feed stuff form the previous manager, but having just the connectors is pretty sharp looking.

I tried downloading the manager and running it, seems like it keeps getting anchored in a weird spot of my screen. :anchor:

3 Likes

Clearly, the problem is in your screen :rofl:

Now seriously… thanks for reporting this as always! We’ll have a peek at this as soon as possible :slight_smile:

1 Like

Yup, there seems to be an issue with screen scaling! Thanks for reporting :slight_smile:

Scaling Issue fixed @haitheredavid , if you close and reopen it, it should auto update to 2.0.10

4 Likes

:sleepy:

Screenshot 2022-07-26 at 09.25.49

At launch.

Got the same just now:

Am I save to assume we’re both running this on bootcamp?

1 Like

I never assume anything. But, indeed, I am.

Yeah, it’s not related - but just remember glancing something re bootcamp from a previous post of yours, then i got the exact same error, and thought to confirm. It will help @teocomi for debugging later :slight_smile:

I think that was just an issue with the build, can you try downloadin again (2.3) @jsdbroughton @dimitrie ?

It works! Es klappt! Funcționează! Mae’n gweithio! :+1:

2 Likes

Tiny aesthetic bug.

If you set the position to be anything other than bottom right then it will be correct in the settings pane and stay in new position only as long as the manager is still open. The next open from tray will show it in bottom right again (until you click the settings cog and then it jumps to the chosen position)

1 Like

Ouch, and that white border should not be there :grin:, thanks for trying it!

I’m using bootcamp in unity mode. (vmware)

Normal windows are ok - i guess its a systray thing?? No reason to fix that.

Thanks for the upgrade!
Comment from using a computer with strict company policies: previous version of the manager I could install without the need of administration rights (and hence no intervention needed from ICT support), while this version requires installing .NET Runtime 6.0.4, which does need admin rights. I guess there won’t be any way around it?

Hey @kelvin , good point & thanks for trying!

I have found out that .NET6 apps can be deployed as self-contained, meaning you should not need to have the .NET 6 runtime installed.

It will make for a larger installer, but it’s definitely worth it for the reasons you mention :slight_smile:

Can you please try again with this new build: https://releases.speckle.dev/manager2/installer/manager.exe

2 Likes

Hi @teocomi, thanks for the fix, it works like a charm!
The new manager can detect our installed connectors again, which tended to fail with the old one. A quick Dynamo connector installation test also worked.
By the way, I like the new look, very clean!

1 Like

Fantastic & thanks for the prompt reply!

image

Handling downloading alternative versions is a little ‘odd’.

Choosing 2.70 across the board, the Grasshopper installed 2.7.1 beta, and Revit fails with the above error.

Thanks! I think I spotted these already, a fix is coming :smiley:

1 Like