List of streams missing on Sketchup

I am just tyring out the latest version of the connector with Sketchup 2013 (23.0.397), installation works, but unfortunately it is not able to load the list of streams (the two buttons on the top appear, but no list). Also adding a stream by using a direct URL does not work (no error, nothing… it just seems to do nothing).
Can you help me please?

Hey @Dietmar_Siegele welcome to the forum!

Could you post a quick gif/video of the issue? Are you using the XYZ server or a custom one?

Can you please also confirm if any other connectors are working for you? It sounds like this might be a firewall/vpn issue. Here are some domains the connector needs access to.

Our lead dev on SketchUp @oguzhankoral is away this week, but we’ll have a look asap.

Hello again,

I have recorded here the behaviour. The window stays like this. Clicking to the buttons open the modal, but a click to “save” or “add” does nothing.

I use the XYZ server. All other connectors works very well (Revit, Blender, QGIS,…).
I checked the firewall and switched it even off temporarily, but no change…


1 Like

Hi @Dietmar_Siegele,

I tested with same version of Sketchup (23.0.397) and couldn’t reproduce it. Somehow your plugin doesn’t fetch the streams from server. Can you provide me some details by following below 2 steps separately.

Error investigation on Sketchup

  1. Open Sketchup
  2. Before running Speckle Connector open the Ruby Console from Extensions > Developer > Ruby Console
  3. Open Speckle Connector and send me screenshot of the console.

Error investigation on User Interface

  1. Open Sketchup
  2. Open Speckle Connector
  3. When UI appeared, right click the UI and open Show Dev Tools
  4. From top tab control, navigate to second tab menu which is Console
  5. Send me screenshot of the console.

Hope we will figure it out the problem.

Here we are:

The Ruby console:

The UI console:

Interesting behaviour, as the connectors wants to connect to our local Speckle server, which is not anymore running. But in the Speckle Manager I deleted that server and it is also not anymore visible:

Hi @Dietmar_Siegele,

Somehow SketchUp Connector doesn’t detect your account information. Not sure but somehow your source file at the AppData corrupted. What I suggest,

  1. Make sure that you are using latest version of Speckle Manager
  2. Remove account by Speckle Manager
  3. Remove Accounts.db file and Accounts folder from %APPDATA%/Speckle. (You can reach the folder as below image)
  4. Then add account again

Hope this helps.

1 Like


thanks for your input!
I tried it out, but unfortunately it did not work. I also tried to uninstall the Speckle Manager, delete the whole %APPDATA%/Speckle and reinstalled it. But also that did not work. It is still the same error. Any other idea where these kind of data is stored and can be delete?

Thanks again!

Then this appears to be in issue with the service provided by your local Speckle Server. I’ll check with the appropriate team and get back to you asap.

If you connect to the as a test, does the issue go away??

As explained, we are not using the local server anymore (so also the account is deleted since a while from the Speckle Manager). We use actually only! No other (local) accounts connected. So for me the question is if there is another way to reset all settings? As uninstall, deleting all files in %APPDATA% and reinstall did not work…

My mistake - I was only looking at the errors. So it is trying to connect to the old local server despite having only XYZ accounts attached.

Exactly! We use only XYZ server now. The old local server does not exist anymore.

1 Like

Hey @Dietmar_Siegele ,

Sorry for the late reply. Would you be up for a quick debug sesh? We really want to solve this issue.

I appreciate that. Sure, I am always available :slight_smile:

Problem solved thanks to @Dietmar_Siegele. It was a caching old local server info on the localStorage of the UI. This looks like an edge case that already issued to fix it on next release. Till then, incase if anyone face with the similar issue here is the solution:

  • Open SketchUp
  • Open Speckle
  • Right-click UI of the Speckle
  • Open Show Dev Tools
  • Navigate to Application Tab Menu
  • Clear localStorage cache as below

1 Like