Linked Elements to Speckle via Dynamo

I’m trying to export some elements to speckle via dynamo and Revit but I’m not able to get the export to work.

In Dynamo the elements are ceilings from a linked model (all elements exported to speckle are linked elements) and the list is flattened.

In Revit the 3D view contains only linked ceilings but once the export is complete still no geometry appears in Speckle.

When exporting a 3D view under the advanced settings you can select to export linked models, but in Dynamo how is this setting controlled?

1 Like

Hi @MitchR;

Sorry for the late reply. We have identified a bug in the Dynamo Connector (Send Node). As you can see here another user is experiencing the same problem.

We are already investigating and trying to solve the problem. In the meantime, you can send data and Linked models from the Revit 2.19 connector.

Can you let us know what Revit, Dynamo and Speckle Connector versions you are using?

Thank you and sorry for the inconvenience.

Hey @Nikos,

I’m using speckle on Revit 2024, Dynamo v.2.19.3, Speckle versions 19.1.

I tried exporting using the updated Revit Connector but I’m getting a new error.

image

1 Like

Hey @MitchR,

I’m sorry to hear that you are having another problem.

This error is an internal Revit API error. To resolve it, we will need an example file.

Is it possible to share your model or the part of the model that is causing the error? We need to run it locally in order to debug the issue.

You can drop your file in this safe link if you can.

Thank you and sorry for the inconvenience.

Nikos

1 Like

I’ve tried to replicate the behavior on some fresh models, it doesn’t give an error anymore when I export from Revit via the Revit Connector but it doesn’t appear in the speckle viewer.

I did an export from the model with the ceilings which did work straight away.

I added the models the google drive, ‘Speckle Ceiling Test’ is linked into ‘Speckle Link Test’, then the 3D view “3D-Ceiling” is exported to Speckle.

Hey @MitchR,

Thanks for sharing the model with us! I will have a look ASAP:

In the meantime, and because you mentioned that you are using Linked files, can you make sure and confirm that you have ticked the Linked Option under the advanced settings?

Thank you!

Yup I’ve always got it ticked

1 Like