IFC processing error log

We have extended the time of processing up to one hour. But medium size files (~30 mb) don’t succeed in parcing. Small note reports about error.
Colleagues, I have two simple questions about ifc:

  1. Main: do you plan to increase the speed of processing? 10 min+ is a little bit discouraging.
  2. Is the log with error available for download somewhere in interface?

If you need any help in testing the import option or need any logs please feel free to contact with me. IFC files processing for us is one of the main functions.


Hi @PavelNedviga - thanks for putting the effort and time into this. It probably has to do with the parser we’re using, namely web-ifc.

Beyond sending us the model, can you let us know if it loads up fine in the demo app from ifc.js peeps here: IFC.js?

If yes, we’ll need to look into it closer on our end. It means the problem is in getting all the elements’ metadata (this is something the demo app doesn’t do upfront, as we do, but only does on selection).

If not, do report this to the ifc.js community, as they’re always up for finding and fixing edge cases!

a rant ffs ifc files are pain in the proverbial place to deal with. it seems that the exception is when they work as expected :/


I guess I have same problem. All ifc models I try to load gives an error message except the model containing only space objects. But it seems that spaces cannot be displayed (maybe transparency settings?). Appears text saying “No displayable objects found in object e71c1ca…”

Whole model loads up perfectly in the demo app from ifc.js (except spaces)

I’m new with Speckle so it’s possible that i’m doing something wrong :slight_smile:


1 Like

Heya @ElsaK, would you mind sending us that file to test against it? I’ll ping you via a direct message on the forum with contact details!

PS: we’d be happy to sign an NDA if needed.


Good news everyone! Once this PR is merged we’ll have much better IFC file imports - like seriously better (think ±30x faster imports, property set support, etc.)

@ElsaK, your file works wonderfully with the new parser. Once we push the update I’ll ping you (and @PavelNedviga) to try it out again on our testing server!


The update is live. But, as always SIGH things work wonderfully on my computer but not on our kube cluster - there are files that locally go through fast but fail in production.

Cautiously, do give it a try. In the meantime, I’ll have steal @iainsproat and @gjedlicska (i hope they don’t hate me too much already) to debug remotely and see what deal is. I hope it’s a simple matter of resource allocation for the converter node, but you never know.

1 Like

I have managed to get ifc model to speckle but I have to import it first to Revit and then use “Speckle for Revit 2022”. Is that a correct workflow?

How large is your IFC file @ElsaK ?

You can directly upload <25MB within the web frontend

I’ve just checked the upload function with 14mb IFC file. It finished with error status, but much more faster. 30x anyway seems to be great gap on the opposite to what we had before. Hope your investigation @dimitrie will be finished soon)

1 Like

The Problem has solved! Now it works with the file size of 95 000 kb. Thanks!


Hi @PavelNedviga, PLEASE GIVE ME THAT FILE if you can!!! The funny thing about IFC file sizes is that they’re are not a good indicator of processing speed/efficiency - see @ElsaK’s 95mb file smoothly working (PS: happy it works for you now, @ElsaK & thanks for sending the file earlier!).

We’ve solved partly some problems of running the parser in production, but we might need to allocate more resources to it. If I have your file, I can test to see if it processes locally and benchmark memory consumption to understand better the production environment needs.

1 Like


I think there are still problems with processing the ifc spaces. No spatial objects are visible in the visualization even though they are in the ifc model

Hello, @dimitrie

I’ve just finished to test the ifc import on our local server, updated to the last version. The report error is displayed on the screeshot.

If I could somehow provide any additional info, please inform me.

I’ve noticed that too :grimacing: Does the previous file you’ve sent me have spaces? If so, I can use it to debug. If not, will happily take a small IFC file with some spaces that i can iterate fast on :slight_smile: I only have a revit derived one that’s quite fat and cumbersome to work with.

That is a weird error, and does look more like a server misconfiguration issue. It’s going to be tough to debug. Can you let us know how your local server is set up?

2 posts were split to a new topic: Spaces/Rooms Exceed Roof

Did you managed to resolve the “space problem” @dimitrie?