Failed to bake object in Rhino

Hello everyone!

I am new to Speckle and really excited about it. Currently, I am still playing around with this tutorial. But when I try to receive the model inside Rhino, the Speckle stream shows the following warning,

Failed to bake object ac12ed56a7ce068fec123ead84670e88 of type Objects.Geometry.Mesh: ON_Mesh.m_F[218] has degenerate double precision vertex locations.

Any idea how to fix it? FYI, I use Rhino 7 and Revit 2021.


1 Like

Hi @fauzanalfi!

Welcome to the community! If you feel like it, you can Introduce yourself 🙆 to everyone here :slight_smile:

That sounds like some nasty error… I’m going to check on my side to see if I can reproduce it, but meanwhile:

  • could you let us know what version of Speckle Manager and the Revit and Rhino connectors you have installed?
  • What units are you using in your Revit project? and in Rhino?

Thanks for reporting this! :slight_smile:

Hi @AlanRynne!

Thanks for your prompt response.

I am using:

  • Speckle Manager v2.1.5
  • SpeckleConnectorRhino v.
  • SpeckleConnectorRevit v.

Both Revit and Rhino projects are using metric units (meter and millimeter). Actually, I didn’t change any unit setting in the Revit and Rhino files provided by the tutorial.

1 Like

Great! Thanks for that!

We’ll keep you posted when we I get any updates on this :+1:

1 Like

Closing this as newer releases fixed this issue.