Error while installing Speckle for Blender


I’m trying to install Speckle in Blender (3.6.2, just installed), using the manager (I’m on Windows 11).

It works fine with Rhino, but when I toggle on the Speckle Addon in the Blender Addons list, I get the following error:

Any idea what I could do to debug this?
I’ve tried uninstalling and reinstalling everything but it doesn’t change anything.

Thank you!

We’re currently investigating this one, other users have reported the same issue.

Some users have found some success by uninstalling both BlenderBIM and Speckle Blender plugins, and reinstalling both.

Please could you give this a try and let us know the results.

I’ll try that, thank you!

Its working, I followed these steps:

  • Uninstall both BlenderBIM and Speckle
  • Install Speckle for Blender (not with the manager)
  • Install Speckle Manager

Maybe it works installing directly with the manager.
For now I’ve not tried reinstalling BlenderBIM :sweat_smile:

1 Like

Glad to here you have got something working.

If you do get the chance to reinstall BlenderBim, please do let us know the results.

Additionally, if you can let us know what version of BlenderBim you did have installed originally, that might help our investigation. But no worries if its too late to check now :grin:

I installed it from the latest version available today at Download - install the BlenderBIM Add-on for Windows, Mac, and Linux, so v0.0.230902

Yes it’s working when I install this version of BlenderBIM AFTER Speckle (alpha 2.16) :slight_smile:


Even just Updating BlenderBIM AddOn usually means :

  • deactivate BlenderBIM first
  • Restart Blender
  • Uninstall Blender
  • from that point you can reinstall or update BlenderBIM from external Zip File again

If you forget the deactivation before and the Blender restart,
Blender will not delete all previous AddOn components and following installation
will usually corrupt.

So maybe that (tedious) procedure may also help or be needed for Speckle AddOn
reinstallation in some cases ?