Dynamo code block not working in Revit 2023

I track down my code block issue to the Speckle addin.
Basically the problem is that i cannot edit a code block if Speckle is loaded.

Raven from Bird Tools use to have the psame problem and it’s fixed now. Raven issue was with restsharp if that helps

Hey @DanielHurtubise ! Thanks for reporting, it’s quite unusual as we’ve been testing Speckle and used code blocks all the time. Also, Speckle is not using restsharp…

What version of the Speckle plugin are you using?

In the meantime, we’ll double-check on our side!

I’m running 2.8 but i can update to the latest beta.
Also we can organize a call if you want

Hi @DanielHurtubise ;
I faced the same issue with Dynamo 2.13. But no idea whether it is because speckle Addin.
So, I installed diroots app manager and disabled all the Revit Addin. Then open the Revit and run the Dyanmo and the code block issue was no more there. Then I close the Revit and enabled all the plugins again and then I checked the dynamo code block. Everything is working fine.

Ok, it seems that the issue is related to the Revit Connector when using Revit 2023.
If only using the Dynamo Connector, the block work just fine…

We’ll debug and let you know asap!

2 Likes

Hi @teocomi
Do u mean Revit 2023 or Revit 2013?

2023! Sorry :sweat_smile: that was a typo

Okay, this might be a complicated one; I’ve reached out to the Dynamo team to see if they have any hints:

In the meantime, I can confirm that you just need to uninstall our Revit plugin and not the Dynamo one to get the code blocks working again.

1 Like

Hello, Any update ion the fix :slight_smile:

Hello @McLean and welcome to the forum!

Unfortunately not much progress, we’re working on this with the Dynamo team, you can follow the conversation on the Dynamo forum as well: Code Block not working due to conflict - #11 by teocomi - Developers - Dynamo

For now you can disable/uninstall the Speckle plugin for Revit to get the code blocks to work again. But if you feel adventurous, I can share with you a local build of Dynamo that seems to be working well with Speckle :slight_smile:

Indeed the latest version doesn’t fix the issue
Keep us posted :slight_smile:

Hi @teocomi , can publish to test it in this post, same problem in my computer ?

Hey @chuongmep,

Here is a build of Dynamo that works with Speckle. Please use at your own risk and make sure to backup the original version of Dynamo in case you want to restore it.
Steps to use it:

  • backup and delete the C:\Program Files\Autodesk\Revit 2023\AddIns\DynamoForRevit folder (this is the current Dynamo shipped with Revit)
  • download my build of Dynamo from here and unzip its contents inside you favourite addins folder, like %appdata%\Autodesk\Revit\Addins\2023
  • start Revit and enjoy using your code blocks again :smiley:

NOTE: you will see a couple of error messages when starting Revit about Dynamo missing, you can ingore them

2 Likes

Quick update, we found another workaround that is actually simpler @chuongmep @DanielHurtubise @McLean @Shafeekh .

Disable GenerativeDesignForRevit by moving it outside from the folder C:\Program Files\Autodesk\Revit 2023\AddIns; Your code blocks will start working again :slight_smile:

We’ll hopefully find a better solution soon :slight_smile:

6 Likes

That is awesome, thanks @teocomi

2 Likes

lol, generative design. That’s why! I was wondering why it works in 2022 but not in 2023. Guess what, I have generative design installed in 2023.

1 Like

Hello, I just whant add that I did what you said and it is working, I moves it not too far :slight_smile:

2 Likes