Could not connect into speckle from Revit or Civil 3D

I am getting a message like this while trying to connect to speckle from Revit or CIvil 3D. I can login to my account from browser! Any idea. I uninstalled speckle manager and all speckle add-ins, then reinstalled the latest versions. But the issue still there.

Is this a new problem? Or, is it the first time you have tried using Connectors for Revit and Civil3D?

This first time I am facing this issue!

I was able to connect to speckle before, and the speckle manager also connected.

That’s curious then.

To try and pin down what has changed, did you just upgrade the connectors and find this issue, or has nothing changed since the last time everything worked for you?

The issue was there with the installed speckle. So, I uninstalled everything and installed the latest version from the manager. I was using speckle while I was in India; I moved to Saudi recently and this is first time I am using speckle after moved into Saudi and got this issue.

You can connect to the internet to get the connectors installed. So your browser works, and the manager works. What is missing is the connectivity from within those two applications.

Are you in an office, networked environment?

Is there a firewall in-between you and the public internet?

Actually, I thought it might be due to my wifi in office. But I tried to connect using my mobile hotspot. Method did not work. Getting the same error.

I could not find the speckle program in my firewall list. I provide Revit full access in public and private network in windows defender firewall setting.

The problem got resolved once I connect through the LAN cable. But in WIFI the problem persists!

1 Like

In which case, it sounds like it isn’t directly a Speckle issue.

Short of your wifi router has a firewall, but there is a limit to what we can advise on this.


Understood. However appreciate your help!