Civil 3D Connector not showing in App Ribbon


I have installed the connector for Revit and also Civil 3D (v2022) and whilst the app shows in Revit I cannot see this in Civil 3D. I have restarted computer, uninstalled, reinstalled a few times but this still doesnt appear. I have also tried typin speckle in the command line and the command is not recognised. It did say it had installed successfully but I cant get it working at all on Civil 3D.

Any help would be greatly appreciated.

Many thanks

Hey @maf4050 welcome to our community! This sounds very similar to:

Can you please share the exact version (with service pack etc) and language?


English UK

The product version is noted as Autodesk Civil 3D 2022
Built on S.51.0.0 Autocad 2022, Autodesk AutoCAD Map 3D 2022, AutoCAD Architecture 2022

I enabled the beta to see if that made a difference but it didnt appear either in Civil 3D. The Revit connector works fine but just not the Civil 3D. Both the Revit and Civil 3d installs are currently on trial versions - I will test on another PC in work tomorrow but it would be great to get this working on my home PC for testing puposes.

Many thanks for your help

Hi @maf4050, I checked on my end and have the same exact versions…
Let us know how it goes on your work PC so we at least have additional data points!

The only thing I can think of checking is if the registry keys were set correctly and if you have the same structure. It should look like the below:

But we can hop on a quick call if you don’t know where to find that :slight_smile:

Having the same issue - note that I have tried both installers and the reg key hasn’t even been created for 2022.

Hey Nicolas, welcome to the forum, and thanks for reporting this!

Could you please share a screenshot showing what you see under:

  • Computer\HKEY_CURRENT_USER\SOFTWARE\Autodesk\AutoCAD\R24.1

And as well under (assuming you are using the english version):

  • Computer\HKEY_CURRENT_USER\SOFTWARE\Autodesk\AutoCAD\R24.1\ACAD-5100:409\Applications\

Are you using a local machine or maybe you’re remoting into a virtual computer / have some unusual set up maybe?


@Nicholas_Hobson @maf4050

Super late, but just figured out the issue for this: Civil3D UK English installs use registry code 809 instead of 409

This should be fixed in manager soon, it would be great if one of you could confirm if you see the Speckle plugin in your add-in ribbon tab after install now!



I am running into similar issues where my connector does not show up. I’ve downloaded the latest connector here, and installed it normally.

How do I go about solving the registry code so I can use Speckle with C3D?

EDIT: the installer through the manager worked fine and solved the problem.