Can't receive streams in self-deployed server

Recently updated my self-hosted server (see here - Manual server deployment issue - #12 by imanwarsame).
Now however, I can’t receive or send streams in Grasshopper

And I also can’t receive streams using the viewer API getting this error

Access to fetch at '' from origin 'http://localhost:5173' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. If an opaque response serves your needs, set the request's mode to 'no-cors' to fetch the resource with CORS disabled.

This wasn’t happening before updating the server and for some reason it works for one stream, but not the others

1 Like

sounds like local tokens have expired or similar.

try removing and re-adding your account for that server in the Manager

Might the functional stream be “Link Shared”

1 Like

Hi @jonathon, link shared is on for all streams. And removing and readding the account didn’t work

Other users also cannot sign in or create accounts on the server and are getting a 403 forbidden error, same as in grasshopper

This was caused by IT rules implemented by my organisation that I wasn’t aware of, all fixed now!